summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorManuel Rüger <mrueg@gentoo.org>2015-12-20 11:00:33 +0100
committerManuel Rüger <mrueg@gentoo.org>2015-12-20 11:00:33 +0100
commit5ec01c239087d8741634727ca2fa08581fd35e90 (patch)
treecfb86e009dabe2fb011e4002cc75fbaa77d50aa9 /app-text
parentdev-ruby/coffee-rails: add 4.1.1 (diff)
downloadgentoo-5ec01c239087d8741634727ca2fa08581fd35e90.tar.gz
gentoo-5ec01c239087d8741634727ca2fa08581fd35e90.tar.bz2
gentoo-5ec01c239087d8741634727ca2fa08581fd35e90.zip
app-text/poppler: Version bump
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-0.39.0.ebuild122
2 files changed, 123 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index fc720ef53c23..004a4ff113b5 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -2,3 +2,4 @@ DIST poppler-0.32.0.tar.xz 1609624 SHA256 4963e31ba5e17530a87b16588e22928bc044e8
DIST poppler-0.36.0.tar.xz 1629984 SHA256 93cc067b23c4ef7421380d3e8bd7c940b2027668446750787d7c1cb42720248e SHA512 36f7ea892d05c73d2862b6d5a29753cfe6823f54f8449e010b9960b59d9c698ba4f239625e8dbf41a235ae61203d8b445f775f5622b38c6d24328870e77371c5 WHIRLPOOL 4111ab5146a65ef4485ff010b9056dfd6573c9d72af3d07c5a16bde49c25ded5c05e26285d672e33a06b05845fdfef240170359ebe4547191a7ca695a91e3e90
DIST poppler-0.37.0.tar.xz 1636496 SHA256 b89f9c5eae3bbb1046b0f767714afd75eca102a0406a3a30856778d42a685bee SHA512 9cdff2da9d13b8db25a24e8703ab411da1caa6545cd25b6153ce019c185cd90eda8dbb59a5c320ea6e8ec1896b0197987acc72ba233d6ece4e212a2132a6b087 WHIRLPOOL 8dda998aac39d86caf215a4c9f3019918282e800d37a29e8f686527e6f2eba6177dbd70968254085008b7a86e34327cbb80b01473a52bf941ad9ad3511fe2341
DIST poppler-0.38.0.tar.xz 1637772 SHA256 6f0c0d49c8346d7c0cfe6348124e7f19cc901b5d35c9cd89944aac6e454e8a8b SHA512 1b8643c0f58eb1e1c3d98266c38d311c66458168188146af72c99c9f374882bdc616aa3febd8833538b286652c21a567e6240aa590111bcebcba5ee845e6bad9 WHIRLPOOL 05a75ca4ed3741273eefe003026caa1f9bb1e3d9f08d1e3885d2fddd7704349434b6deb1f9e755312d7a5b040e85435b0baa92f4934c4d220b1ea8625ebff4f5
+DIST poppler-0.39.0.tar.xz 1641156 SHA256 afd75befa9c3a41e1d7755c4e43dea70cfd8f1a4dac118e83032cbb41ce17bb9 SHA512 046a80d5cbbdf1dda57ebcd09a77eb80239a85b0d8250d89174e5a69ce171000c4ab624f6c00b599b30d4ed2559976c8e527b3ed65f04c6d3f582c3e2b75e522 WHIRLPOOL 5722c48d0d2278134f7fa353d327a6fed0ae63b96f0f1e8edd2107c9d7012a8e95d2996887e415e4cfe525cf64b7d5630c75620376fc075297397fd57f7f2be7
diff --git a/app-text/poppler/poppler-0.39.0.ebuild b/app-text/poppler/poppler-0.39.0.ebuild
new file mode 100644
index 000000000000..c8f78de23c1a
--- /dev/null
+++ b/app-text/poppler/poppler-0.39.0.ebuild
@@ -0,0 +1,122 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit cmake-utils toolchain-funcs
+
+if [[ "${PV}" == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="git://git.freedesktop.org/git/${PN}/${PN}"
+ SLOT="0/9999"
+else
+ SRC_URI="http://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~amd64-linux ~ia64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/58" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="http://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="cairo cjk curl cxx debug doc +introspection +jpeg +jpeg2k +lcms png qt4 qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+COMMON_DEPEND="
+ >=media-libs/fontconfig-2.6.0
+ >=media-libs/freetype-2.3.9
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ >=x11-libs/cairo-1.10.0
+ introspection? ( >=dev-libs/gobject-introspection-1.32.1 )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( media-libs/openjpeg:2= )
+ lcms? ( media-libs/lcms:2 )
+ png? ( media-libs/libpng:0= )
+ qt4? (
+ dev-qt/qtcore:4
+ dev-qt/qtgui:4
+ )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+DEPEND="${COMMON_DEPEND}
+ virtual/pkgconfig
+"
+RDEPEND="${COMMON_DEPEND}
+ cjk? ( >=app-text/poppler-data-0.4.4 )
+"
+
+DOCS=(AUTHORS NEWS README README-XPDF TODO)
+
+PATCHES=(
+ "${FILESDIR}/${PN}-0.26.0-qt5-dependencies.patch"
+ "${FILESDIR}/${PN}-0.28.1-fix-multilib-configuration.patch"
+ "${FILESDIR}/${PN}-0.28.1-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.33.0-openjpeg2.patch"
+)
+
+src_prepare() {
+ cmake-utils_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if [[ ${CC} == clang ]] ; then
+ sed -i -e 's/-fno-check-new//' cmake/modules/PopplerMacros.cmake || die
+ fi
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT4_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DENABLE_SPLASH=ON
+ -DENABLE_ZLIB=ON
+ -DENABLE_XPDF_HEADERS=ON
+ $(cmake-utils_use_enable curl LIBCURL)
+ $(cmake-utils_use_enable cxx CPP)
+ $(cmake-utils_use_enable utils)
+ $(cmake-utils_use_with cairo)
+ $(cmake-utils_use_with introspection GObjectIntrospection)
+ $(cmake-utils_use_with jpeg)
+ $(cmake-utils_use_with png)
+ $(cmake-utils_use_with qt4)
+ $(cmake-utils_use_find_package qt5 Qt5Core)
+ $(cmake-utils_use_with tiff)
+ )
+ if use jpeg2k; then
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=openjpeg2)
+ else
+ mycmakeargs+=(-DENABLE_LIBOPENJPEG=)
+ fi
+ if use lcms; then
+ mycmakeargs+=(-DENABLE_CMS=lcms2)
+ else
+ mycmakeargs+=(-DENABLE_CMS=)
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_install() {
+ cmake-utils_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != 9999 ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}