summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarek Szuba <marecki@gentoo.org>2022-01-03 23:13:17 +0000
committerMarek Szuba <marecki@gentoo.org>2022-01-03 23:14:40 +0000
commit6608b3c86cb94ede801535174eb8ddca68644e24 (patch)
tree0e26b0b44a74613e5f586102ab7929c76ab4b834 /app-text
parentnet-misc/oidc-agent: add 4.2.5 (diff)
downloadgentoo-6608b3c86cb94ede801535174eb8ddca68644e24.tar.gz
gentoo-6608b3c86cb94ede801535174eb8ddca68644e24.tar.bz2
gentoo-6608b3c86cb94ede801535174eb8ddca68644e24.zip
app-text/xchm: add 1.33
Still EAPI 7 for now because switching to 8 results in rather spectacular linking failures. Signed-off-by: Marek Szuba <marecki@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xchm/Manifest1
-rw-r--r--app-text/xchm/xchm-1.33.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/xchm/Manifest b/app-text/xchm/Manifest
index 9c6fdafff110..31e62a672456 100644
--- a/app-text/xchm/Manifest
+++ b/app-text/xchm/Manifest
@@ -1 +1,2 @@
DIST xchm-1.32.tar.gz 986604 BLAKE2B f2a1d27ee747bb2d599452f1fa91864afbd2d604e9c27322d70c0925c9c313d4c80ab647ed5bb7ae3672687decfaafb2be23f7b9ed09fb95ae7490b0a65d7cab SHA512 e8250660ff28c80ddda62b886b296d98fb60e8d482ad6791c775a51a860ca78e310222bd0f5baa40c941a3f345c0bb07edb932c0417835ab0b090d14b7b4c0f6
+DIST xchm-1.33.tar.gz 886169 BLAKE2B 26b6c664307de3ef1bef21d3fd240b5636f5abc8196c5aa1b7cd6b91f12addbbd5a8c54d133de2fd8ce9132ea2677f79f0ef722b1da6c87429cd3df54d208585 SHA512 06f5c191ef9f2c608259261839d6641f202a21150a6622b8162e06e3cc857802390f551dcef47f25d048b3d407511c5a8cc6aabd3003942006847366ebb08989
diff --git a/app-text/xchm/xchm-1.33.ebuild b/app-text/xchm/xchm-1.33.ebuild
new file mode 100644
index 000000000000..27f28acfd7aa
--- /dev/null
+++ b/app-text/xchm/xchm-1.33.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+WX_GTK_VER="3.0-gtk3"
+
+inherit desktop wxwidgets xdg-utils
+
+DESCRIPTION="Utility for viewing Compiled HTML Help (CHM) files"
+HOMEPAGE="https://github.com/rzvncj/xCHM/"
+SRC_URI="https://github.com/rzvncj/xCHM/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~riscv ~x86"
+IUSE="nls"
+
+RDEPEND=">=dev-libs/chmlib-0.36
+ x11-libs/wxGTK:${WX_GTK_VER}[X]
+ nls? ( virtual/libintl )"
+DEPEND="${RDEPEND}"
+BDEPEND="nls? ( sys-devel/gettext )"
+
+src_configure() {
+ setup-wxwidgets
+ econf $(use_enable nls)
+}
+
+src_install() {
+ default
+
+ domenu "${FILESDIR}"/xchm.desktop
+ insinto /usr/share/mime/packages
+ doins "${FILESDIR}"/xchm.xml
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}