summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-09-01 22:25:29 +0100
committerSam James <sam@gentoo.org>2021-09-01 22:26:36 +0100
commit680d14101477f478c2116bcb0f401c5472c1682b (patch)
tree7d5e80619f0dc69cad3e03b4d652b71b2355fdf8 /app-text
parentapp-text/poppler: rebase cflags patch for live ebuild (diff)
downloadgentoo-680d14101477f478c2116bcb0f401c5472c1682b.tar.gz
gentoo-680d14101477f478c2116bcb0f401c5472c1682b.tar.bz2
gentoo-680d14101477f478c2116bcb0f401c5472c1682b.zip
app-text/poppler: fix check for Clang
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/poppler-9999.ebuild2
1 files changed, 1 insertions, 1 deletions
diff --git a/app-text/poppler/poppler-9999.ebuild b/app-text/poppler/poppler-9999.ebuild
index 9151fd10198f..2013baa8c3f7 100644
--- a/app-text/poppler/poppler-9999.ebuild
+++ b/app-text/poppler/poppler-9999.ebuild
@@ -70,7 +70,7 @@ src_prepare() {
# Clang doesn't grok this flag, the configure nicely tests that, but
# cmake just uses it, so remove it if we use clang
- if [[ ${CC} == clang ]] ; then
+ if tc-is-clang ; then
sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
fi