summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAzamat H. Hackimov <azamat.hackimov@gmail.com>2023-02-02 10:46:08 +0300
committerFlorian Schmaus <flow@gentoo.org>2023-02-06 13:02:34 +0100
commit6af6add9b707bc0f4b83af28dc72909da42322fc (patch)
treeeadb588eb320f4aef7e003e908e4713720e65464 /app-text
parentnet-im/profanity: add myself as maintainer (diff)
downloadgentoo-6af6add9b707bc0f4b83af28dc72909da42322fc.tar.gz
gentoo-6af6add9b707bc0f4b83af28dc72909da42322fc.tar.bz2
gentoo-6af6add9b707bc0f4b83af28dc72909da42322fc.zip
app-text/cmark: add 0.30.3
Fixes security issue CVE-2023-22486. Signed-off-by: Azamat H. Hackimov <azamat.hackimov@gmail.com> Closes: https://github.com/gentoo/gentoo/pull/29388 Signed-off-by: Florian Schmaus <flow@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/cmark/Manifest1
-rw-r--r--app-text/cmark/cmark-0.30.3.ebuild34
2 files changed, 35 insertions, 0 deletions
diff --git a/app-text/cmark/Manifest b/app-text/cmark/Manifest
index d5eca9eb40ab..1a5d16b9e75f 100644
--- a/app-text/cmark/Manifest
+++ b/app-text/cmark/Manifest
@@ -1 +1,2 @@
DIST cmark-0.30.2.tar.gz 246033 BLAKE2B 487f5adf47afdd4133e16b6cca1403cd555f8722b47c423960909de73aacac1d0f8b16311f6d5349addb5f03a86562545bb2ec80771b822bb8e5b82816375124 SHA512 aaa9b2103cf89c522f9b42a2b43c07ecf75e07eb42214c0be5de17682ea1faf9c85e3dd28fe91d446b69a34f9980bcab6e276a99b42540c40c9ee1481b3a0d17
+DIST cmark-0.30.3.tar.gz 246916 BLAKE2B b63027e1a7d6db21c3b1bfc89deaebb202972cf65b3ddc51f20d6cb2dacfb6724dffd226f3cace1b25dda2cd87bdb201b82779bd7a6068c5f9751513bda226ae SHA512 27383bfef95ae1390c26aff0dd2cbca33704e7d20116bf29da4695d2c9a4146b86daba0da1e91bdb9eab95671702f885e832b3d31d51601731f1dc630df5237b
diff --git a/app-text/cmark/cmark-0.30.3.ebuild b/app-text/cmark/cmark-0.30.3.ebuild
new file mode 100644
index 000000000000..e042b8fbbca9
--- /dev/null
+++ b/app-text/cmark/cmark-0.30.3.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..11} )
+
+inherit cmake python-any-r1
+
+DESCRIPTION="CommonMark parsing and rendering library and program in C"
+HOMEPAGE="https://github.com/commonmark/cmark"
+SRC_URI="https://github.com/commonmark/cmark/archive/${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD-2"
+SLOT="0/${PV}"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64 ~riscv ~x86"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+BDEPEND="test? ( ${PYTHON_DEPS} )"
+
+pkg_setup() {
+ use test && python-any-r1_pkg_setup
+}
+
+src_configure() {
+ local mycmakeargs=(
+ -DCMARK_LIB_FUZZER=OFF
+ -DCMARK_SHARED=ON
+ -DCMARK_STATIC=OFF
+ -DCMARK_TESTS="$(usex test)"
+ )
+ cmake_src_configure
+}