summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJohn Helmert III <jchelmert3@posteo.net>2020-06-13 01:56:45 -0500
committerMikle Kolyada <zlogene@gentoo.org>2020-06-13 12:35:02 +0300
commit703e79f63d52413d37f850ca62c1cabcc1606d70 (patch)
tree8268bd398d1f676c401b5c9552fc5468dfb31438 /app-text
parentsys-libs/pam: Respect portage host cc variable (diff)
downloadgentoo-703e79f63d52413d37f850ca62c1cabcc1606d70.tar.gz
gentoo-703e79f63d52413d37f850ca62c1cabcc1606d70.tar.bz2
gentoo-703e79f63d52413d37f850ca62c1cabcc1606d70.zip
app-text/djvu: Security bump
Bump to upstream tag debian/3.5.27.1-14, which includes fixes for numerous security issues. Bug: https://bugs.gentoo.org/536720 Bug: https://bugs.gentoo.org/718552 Package-Manager: Portage-2.3.100, Repoman-2.3.22 Signed-off-by: John Helmert III <jchelmert3@posteo.net> Closes: https://github.com/gentoo/gentoo/pull/16210 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/djvu/Manifest1
-rw-r--r--app-text/djvu/djvu-3.5.27-r2.ebuild73
2 files changed, 74 insertions, 0 deletions
diff --git a/app-text/djvu/Manifest b/app-text/djvu/Manifest
index 78edcda5cc8c..3d21b0b09da9 100644
--- a/app-text/djvu/Manifest
+++ b/app-text/djvu/Manifest
@@ -1 +1,2 @@
+DIST djvu-3.5.27.zip 3567522 BLAKE2B c074468a2fedf097b9b8fea4c449f26b61bffb31d10114081554e59256a23315ecffc203b5223468ca0c3338118b53aba65eee4cb5e7ad5c8d55470e90f43843 SHA512 dc1cd1bce2fb6245946f9409b3a3826ef2dc77a20be079c929b17508c3d967a0b5d8acd61bad00357e46a845f7f97717a043db9ffd1fe23e9a09441b7d21cbd6
DIST djvulibre-3.5.27.tar.gz 3648522 BLAKE2B e1907b4b64c48304ceb24360cfd451e4690d38803f22231d4e136dbe754715527fa0300c623bb709fa05bba206348257137b2a755651bb51ca26259680e142d0 SHA512 62abcaa2fe7edab536477929ba38b882453dab1a06e119a3f838b38d5c61f5d8c252e4769e6534582b826e49bcfb490513179580fab9c3afa84aa92053ccebee
diff --git a/app-text/djvu/djvu-3.5.27-r2.ebuild b/app-text/djvu/djvu-3.5.27-r2.ebuild
new file mode 100644
index 000000000000..d02340cef05d
--- /dev/null
+++ b/app-text/djvu/djvu-3.5.27-r2.ebuild
@@ -0,0 +1,73 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools desktop eutils flag-o-matic xdg-utils
+
+COMMIT="a00b7618c22fb35b030582147a4479c4cf41c349"
+MY_P="${PN}-${PN}libre-git-${COMMIT}"
+
+DESCRIPTION="DjVu viewers, encoders and utilities"
+HOMEPAGE="http://djvu.sourceforge.net/"
+SRC_URI="https://sourceforge.net/code-snapshots/git/d/dj/djvu/djvulibre-git.git/${MY_P}.zip -> ${P}.zip"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-solaris"
+IUSE="debug doc jpeg tiff xml"
+
+RDEPEND="jpeg? ( virtual/jpeg:0 )
+ tiff? ( media-libs/tiff:0= )"
+DEPEND="${RDEPEND}
+ || ( gnome-base/librsvg media-gfx/inkscape )"
+BDEPEND="app-arch/unzip"
+
+S=${WORKDIR}/${MY_P}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ use debug && append-cppflags "-DRUNTIME_DEBUG_ONLY"
+
+ # We install all desktop files by hand.
+ econf \
+ $(use_enable xml xmltools) \
+ $(use_with jpeg) \
+ $(use_with tiff) \
+ --disable-desktopfiles
+}
+
+DOCS=( NEWS README )
+
+src_install() {
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ use doc && dodoc -r doc
+
+ # Install desktop files.
+ cd desktopfiles
+ for i in {22,32,48,64}; do
+ insinto /usr/share/icons/hicolor/${i}x${i}/mimetypes
+ newins prebuilt-hi${i}-djvu.png image-vnd.djvu.png
+ done
+ insinto /usr/share/mime/packages
+ doins djvulibre-mime.xml
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+ has_version app-text/djview || \
+ optfeature "For djviewer or browser plugin" app-text/djview
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_mimeinfo_database_update
+}