summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJonas Stein <news@jonasstein.de>2017-11-01 12:56:08 -0600
committerNicolas Bock <nicolasbock@gentoo.org>2017-11-01 12:57:28 -0600
commit726d559fb610fe987d8b434c56c7f3d7df89b349 (patch)
tree6d8c7b7a6b5934ca51800ffc10ce91714de4f7f3 /app-text
parentapp-text/jabref-bin: Update dependencies (diff)
downloadgentoo-726d559fb610fe987d8b434c56c7f3d7df89b349.tar.gz
gentoo-726d559fb610fe987d8b434c56c7f3d7df89b349.tar.bz2
gentoo-726d559fb610fe987d8b434c56c7f3d7df89b349.zip
app-text/jabref-bin: Add live ebuild
Live ebuild fetches daily snapshots of the from upstream. Package-Manager: Portage-2.3.8, Repoman-2.3.3 Signed-off-by: Nicolas Bock <nicolasbock@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/jabref-bin/jabref-bin-4.9999.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/jabref-bin/jabref-bin-4.9999.ebuild b/app-text/jabref-bin/jabref-bin-4.9999.ebuild
new file mode 100644
index 000000000000..7f9e3811a59c
--- /dev/null
+++ b/app-text/jabref-bin/jabref-bin-4.9999.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils java-pkg-2
+
+DESCRIPTION="Java GUI manages bibliographies in a BibTeX database"
+HOMEPAGE="http://www.jabref.org/"
+KEYWORDS=""
+
+LICENSE="MIT"
+SLOT="0"
+
+DEPEND="app-arch/unzip"
+
+RDEPEND="
+ || (
+ dev-java/oracle-jre-bin:1.8[javafx]
+ dev-java/oracle-jdk-bin:1.8[javafx]
+ )
+ >=virtual/jre-1.8
+ "
+
+S="${WORKDIR}"
+
+src_unpack() {
+ einfo "Downloading the latest Jabref development snapshot."
+ einfo "Upstream updates these a few times per day."
+ wget "https://builds.jabref.org/master/JabRef--master--latest.jar" -O ${P}.jar || die "wget failed"
+ unzip ${P}.jar images/external/JabRef-icon-48.png || die "icon extraction failed"
+}
+
+src_install() {
+ java-pkg_newjar "${P}.jar"
+ java-pkg_dolauncher "${PN}" --jar "${PN}.jar"
+ newicon images/external/JabRef-icon-48.png JabRef-bin-icon.png
+ make_desktop_entry "${PN}" JabRef-bin JabRef-bin-icon Office
+ ewarn "Jabref 4.x will convert old 3.x format .bib databases to a new format."
+ ewarn "The conversion is irreversible, backup .bib files before starting Jabref."
+ ewarn "Jabref 4.x is under heavy development and very unstable."
+}