summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-01-28 16:51:21 +0100
committerMichael Weber <xmw@gentoo.org>2018-01-28 17:18:53 +0100
commit7333539f80c2b814436c746dc0a1c0910719fcc3 (patch)
tree022b7d56ae264fdbb1ba67b73de171be1b4d2e02 /app-text
parentdev-libs/girara: Remove old. (diff)
downloadgentoo-7333539f80c2b814436c746dc0a1c0910719fcc3.tar.gz
gentoo-7333539f80c2b814436c746dc0a1c0910719fcc3.tar.bz2
gentoo-7333539f80c2b814436c746dc0a1c0910719fcc3.zip
app-text/zathura: Version bump.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura/Manifest1
-rw-r--r--app-text/zathura/zathura-0.3.8.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-text/zathura/Manifest b/app-text/zathura/Manifest
index 6999e7b07e21..2cf3597e5bcc 100644
--- a/app-text/zathura/Manifest
+++ b/app-text/zathura/Manifest
@@ -1 +1,2 @@
DIST zathura-0.3.7.tar.gz 174095 BLAKE2B f0025b75b319dbfa397362e102318f1dc1b5dd41f8beb1380cd781fd7594d15234781d862bf20b59ad4bcb9d1aa67210aa10779c19273e81341bfb74962f3139 SHA512 830a1b88820507a40a20b046c504d8ab3022a35c2c4c0d93a67f77ab5e31d746362a6f28fb9786a647cd0bfd943306aca74cbb2092774aedfb52380e713df533
+DIST zathura-0.3.8.tar.gz 174962 BLAKE2B 44d91564ee42cea80357230c789160e37774d5ae29f8de8bac1fbf734a28e7b862d58d807fe3fa01d323d0baaf88a3960243f8022893c3ad40b67ba8d8a1ae6d SHA512 bad10eaf6642885f96850a01921dc1580357144d8b9b27e88e7765e6fc8e7d8f8c94c240904469e1e6b22114be5117a28a24c87183476d2c89d93f27a5083109
diff --git a/app-text/zathura/zathura-0.3.8.ebuild b/app-text/zathura/zathura-0.3.8.ebuild
new file mode 100644
index 000000000000..46c2f8727832
--- /dev/null
+++ b/app-text/zathura/zathura-0.3.8.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils multilib toolchain-funcs virtualx xdg-utils
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86 ~amd64-linux ~x86-linux"
+ SRC_URI="http://pwmt.org/projects/${PN}/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="A highly customizable and functional document viewer"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE="+magic sqlite synctex test"
+
+RDEPEND=">=dev-libs/girara-0.2.8:3=
+ >=dev-libs/glib-2.32:2=
+ x11-libs/cairo:=
+ >=x11-libs/gtk+-3.6:3
+ magic? ( sys-apps/file:= )
+ sqlite? ( dev-db/sqlite:3= )
+ synctex? ( >=app-text/texlive-core-2015 )"
+DEPEND="${RDEPEND}
+ sys-devel/gettext
+ virtual/pkgconfig
+ test? ( dev-libs/check )"
+
+src_configure() {
+ myzathuraconf=(
+ WITH_MAGIC=$(usex magic 1 0)
+ WITH_SQLITE=$(usex sqlite 1 0)
+ WITH_SYNCTEX=$(usex synctex 1 0)
+ PREFIX="${EPREFIX}"/usr
+ LIBDIR='${PREFIX}'/$(get_libdir)
+ CC="$(tc-getCC)"
+ SFLAGS=''
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_test() {
+ virtx emake "${myzathuraconf[@]}" test
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+}