summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 04:07:50 +0000
committerSam James <sam@gentoo.org>2021-12-29 05:34:15 +0000
commit76e5aadbbb8cab1392cf2ba273b95a8550275fca (patch)
tree231400eaf4562d441cca0623108d1f856536023e /app-text
parentdev-python/git-review: 2.2.0 bump (diff)
downloadgentoo-76e5aadbbb8cab1392cf2ba273b95a8550275fca.tar.gz
gentoo-76e5aadbbb8cab1392cf2ba273b95a8550275fca.tar.bz2
gentoo-76e5aadbbb8cab1392cf2ba273b95a8550275fca.zip
app-text/lesspipe: add 2.00
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.00.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index ea1f332fce7b..ba2ef82f29e0 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -2,3 +2,4 @@ DIST lesspipe-1.85.tar.gz 120568 BLAKE2B d2c00f4121dc1bbed6b82220dac038068bbff87
DIST lesspipe-1.89.tar.gz 121118 BLAKE2B e730b6e8afc767a0118abbcc6221d2c18467393119c26baf71b8758b5826ba52230526b9c5cd67704aadda07b63a62dfe006db10de1dbae0a73ede1885b03ed0 SHA512 b8d7c92d3dae77f2ccee8e314af4354fefc9f3aaec1566af02c9be2640f11ebf7ea1432334470c5d5dbce39d2ac7c3e9f4074bcf9ee4a502dc59b370a21b54f5
DIST lesspipe-1.90.tar.gz 121098 BLAKE2B 269f4193f423e4ac5770171156e2f63d14966d7dcc77bf015c3100f281206424ef334acc1edf2edb6fe31f73aed80b9c3ba6c715d6e97993c5a90dfc1ce42405 SHA512 d402bd46c37d2509c90530e9da0560fa3e5da9002c37a515451a8ab9275576d1af44793a10914e74e804f10a3352439815c6763d2d77e5e41a0e9840286f518e
DIST lesspipe-1.91.tar.gz 121965 BLAKE2B 93c169b2b1a81db7e7b569718a43152a8f2b9ea95258047a00ae4940509817a3eb861fdadb6bafc5861c49e805ce910348a57f634bdae57317811ac6fbfc6945 SHA512 d080ceaae019d8885a53c8abb26f4a159b78578f68c2b9a024960aa69509651e3b6638e78bd6e2e57c23d81123d9a3cab167736f253ba4276a3889890d594bd3
+DIST lesspipe-2.00.tar.gz 190295 BLAKE2B 8f950853673e7939d6dd67c5022219ab101eea26b8efec1a7572e3c2c8465a14d09acbe945b204e927444b10953309b27fa47c5661df02e67aa2e2b98a940980 SHA512 f709bae63b17617d2c02bbe691736826c857ba1771907e37ba56bd407a29c2092a936ecb43d6a6e180a1d2eb5f54dccc894d2cf4eb113d42b4892ca6d8a4378d
diff --git a/app-text/lesspipe/lesspipe-2.00.ebuild b/app-text/lesspipe/lesspipe-2.00.ebuild
new file mode 100644
index 000000000000..c6c0557f8a33
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.00.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="test"
+
+BDEPEND="dev-lang/perl"
+RDEPEND="${DEPEND}
+ !<sys-apps/less-483-r1"
+
+src_configure() {
+ # Not an autoconf script.
+ ./configure --fixed || die
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}