summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJakov Smolić <jsmolic@gentoo.org>2021-10-01 08:47:24 +0200
committerJakov Smolić <jsmolic@gentoo.org>2021-10-01 09:24:25 +0200
commit77af0d66746e0f4a282ac25a6641511b082a6fc6 (patch)
treec8dbd229a56cbe9d8571d67906544ed9b289cb7c /app-text
parentsys-libs/libstdc++-v3: update SRC_URI (diff)
downloadgentoo-77af0d66746e0f4a282ac25a6641511b082a6fc6.tar.gz
gentoo-77af0d66746e0f4a282ac25a6641511b082a6fc6.tar.bz2
gentoo-77af0d66746e0f4a282ac25a6641511b082a6fc6.zip
app-text/bibutils: Version bump to 7.1
Signed-off-by: Jakov Smolić <jsmolic@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibutils/Manifest1
-rw-r--r--app-text/bibutils/bibutils-7.1.ebuild43
2 files changed, 44 insertions, 0 deletions
diff --git a/app-text/bibutils/Manifest b/app-text/bibutils/Manifest
index c72c9c3707b5..c4cb296642df 100644
--- a/app-text/bibutils/Manifest
+++ b/app-text/bibutils/Manifest
@@ -1 +1,2 @@
DIST bibutils_6.10_src.tgz 590002 BLAKE2B 91ea6c961978d381a65c1d5071c541409609dd9fdeb664cd7e66eb4871c2ecd0dfd6b06857294ae6ec049751a5939be23518782a5e1f14fdf848918849269402 SHA512 43cf107ee6d1bf6bf27a6bf46e1f4cbd83a4b78ef355730a9f37282fac399ee21d78538248730be85c0a8f724344782dcc6ab68e50f857d8ac4ea24cc4102911
+DIST bibutils_7.1_src.tgz 620141 BLAKE2B f020ea7c8164a870ef4c72defae1adc11558661a7ae9f3b037115cfc4a9e71b4f37c64f3b74641182300c3e921b8a0c309257a468b6b32f4fc2915e4a36f04d1 SHA512 2a155ca60c97d37941c860635d8e6920bd78de84452e1fee93a2f7331392f6a43f2c10055e84349bcac89314025d1524fd5cc73c47ad1613baa7baf2667c3f33
diff --git a/app-text/bibutils/bibutils-7.1.ebuild b/app-text/bibutils/bibutils-7.1.ebuild
new file mode 100644
index 000000000000..a54bd087935e
--- /dev/null
+++ b/app-text/bibutils/bibutils-7.1.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit toolchain-funcs
+
+MY_P="${PN}_${PV}"
+DESCRIPTION="Interconverts between various bibliography formats using common XML intermediate"
+HOMEPAGE="https://sourceforge.net/p/bibutils/home/Bibutils/"
+SRC_URI="mirror://sourceforge/${PN}/${MY_P}_src.tgz"
+S="${WORKDIR}/${MY_P}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+
+src_prepare() {
+ default
+ sed -ie 's/REPLACE_INSTALLDIR/${DESTDIR}&/' Makefile_start || die
+ sed -ie 's/REPLACE_LIBINSTALLDIR/${DESTDIR}&/' Makefile_start || die
+}
+
+src_configure() {
+ ./configure \
+ --install-dir /usr/bin \
+ --install-lib /usr/$(get_libdir) \
+ --dynamic || die
+}
+
+src_compile() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}"
+}
+
+src_test() {
+ emake \
+ CC="$(tc-getCC)" \
+ DISTRO_CFLAGS="${CFLAGS}" \
+ LDFLAGSIN="${LDFLAGS}" test
+}