summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMikle Kolyada <zlogene@gentoo.org>2019-10-27 13:52:08 +0300
committerMikle Kolyada <zlogene@gentoo.org>2019-10-27 13:53:03 +0300
commit7f4a6ec2c73c5f64af0f5f4e3808e8a1820d1ca9 (patch)
treec86804e155348e253d144f23263c89de96ce4548 /app-text
parentkde-plasma/breeze-gtk: Fix python executable selection (diff)
downloadgentoo-7f4a6ec2c73c5f64af0f5f4e3808e8a1820d1ca9.tar.gz
gentoo-7f4a6ec2c73c5f64af0f5f4e3808e8a1820d1ca9.tar.bz2
gentoo-7f4a6ec2c73c5f64af0f5f4e3808e8a1820d1ca9.zip
app-text/zathura-pdf-mupdf: fix build
Closes: https://bugs.gentoo.org/693354 Package-Manager: Portage-2.3.76, Repoman-2.3.16 Signed-off-by: Mikle Kolyada <zlogene@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch11
-rw-r--r--app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild1
2 files changed, 12 insertions, 0 deletions
diff --git a/app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch b/app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch
new file mode 100644
index 000000000000..e031db3c9188
--- /dev/null
+++ b/app-text/zathura-pdf-mupdf/files/0.3.5-compile-fix.patch
@@ -0,0 +1,11 @@
+--- a/zathura-pdf-mupdf/search.c 2019-09-12 11:29:21.527194069 +0200
++++ b/zathura-pdf-mupdf/search.c 2019-09-12 11:30:11.648675352 +0200
+@@ -39,7 +39,7 @@
+ mupdf_page_extract_text(mupdf_document, mupdf_page);
+ }
+
+- fz_quad* hit_bbox = fz_malloc_array(mupdf_page->ctx, N_SEARCH_RESULTS, fz_quad);
++ fz_quad* hit_bbox = fz_malloc_array(mupdf_page->ctx, N_SEARCH_RESULTS, sizeof(fz_quad));
+ int num_results = fz_search_stext_page(mupdf_page->ctx, mupdf_page->text,
+ text, hit_bbox, N_SEARCH_RESULTS);
+
diff --git a/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild
index a8c73f86302b..ec8c60cf28ef 100644
--- a/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild
+++ b/app-text/zathura-pdf-mupdf/zathura-pdf-mupdf-0.3.5.ebuild
@@ -35,5 +35,6 @@ BDEPEND="virtual/pkgconfig"
src_prepare() {
sed -i -e '/mupdfthird/d' meson.build || die "sed failed"
+ eapply "${FILESDIR}"/${PV}-compile-fix.patch
default
}