summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLars Wendler <polynomial-c@gentoo.org>2015-12-27 12:27:58 +0100
committerLars Wendler <polynomial-c@gentoo.org>2015-12-27 12:28:17 +0100
commit818727bc7fb9bdebc93ae94b585363a078e42769 (patch)
tree739b25df61dcc3e8f513176734ff44ee1b6563e4 /app-text
parentdev-libs/libindicate: Stable for HPPA (bug #569830). (diff)
downloadgentoo-818727bc7fb9bdebc93ae94b585363a078e42769.tar.gz
gentoo-818727bc7fb9bdebc93ae94b585363a078e42769.tar.bz2
gentoo-818727bc7fb9bdebc93ae94b585363a078e42769.zip
app-text/docbook-xsl-stylesheets: Bump to version 1.79.1
Package-Manager: portage-2.2.26 Signed-off-by: Lars Wendler <polynomial-c@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/docbook-xsl-stylesheets/Manifest1
-rw-r--r--app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1.ebuild81
2 files changed, 82 insertions, 0 deletions
diff --git a/app-text/docbook-xsl-stylesheets/Manifest b/app-text/docbook-xsl-stylesheets/Manifest
index 476590e3a092..14a3eb749a7c 100644
--- a/app-text/docbook-xsl-stylesheets/Manifest
+++ b/app-text/docbook-xsl-stylesheets/Manifest
@@ -1,2 +1,3 @@
DIST docbook-xsl-1.78.0.tar.bz2 5011106 SHA256 e43220bfe35cad7eb289291264da472819c4b781173a9a58f72d6e404a1f5923 SHA512 9611e354a8c8e86fa203a0b58356a6229e82f98197a94f9a668c10e10ef3ebb87f468fa03a04292068d1cca5ad31043d78e19981933ee3820910d70ca9e044e2 WHIRLPOOL a2ffba19a2da8c6fc1be9fbdc8ef5b5fc5f13ed8524ffc07bda56b7f986268f45b5c4df2261f6a04c7e12b97aadc2e2a6718268ffe3102aa58589f2db6e6f90c
DIST docbook-xsl-1.79.0.tar.bz2 21973361 SHA256 de7ba9cfdc75cb7df4f3e57f080d3a30d97ef2ba6841cbce8bdbd9f6eb43d606 SHA512 5761b9fafe7895a76afacbbf20607fff493fd5a9e3ab4d2f67780c887c24ef12c8313065ea384964a57b6e47d92c7a5167ed16bdf3c4e93576b0af5cb99463ab WHIRLPOOL 45eea4d335d4371d089284f66681702bb0c9b2602f95c7eafe98a22d1ebf9fa621b58a5390ec5735ecece88a104d6e04a7d90e1bd330d71af8d102325ce07853
+DIST docbook-xsl-1.79.1.tar.bz2 21967928 SHA256 725f452e12b296956e8bfb876ccece71eeecdd14b94f667f3ed9091761a4a968 SHA512 83325cbaf1545da6b9b8b77f5f0e6fdece26e3c455164b300a1aa3d19e3bd29ae71fd563553a714a5394968d1a65684c6c7987c77524469358d18b8c227025c7 WHIRLPOOL 3bd03072aba15cda9e7a18cb6c1edfc91cdb706811fd07d5aa69df1ffd5a48394848079cf63c67360104f0c0ec89920268b49d358c62bf5f61d6030938be0a0f
diff --git a/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1.ebuild b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1.ebuild
new file mode 100644
index 000000000000..aeba63242dee
--- /dev/null
+++ b/app-text/docbook-xsl-stylesheets/docbook-xsl-stylesheets-1.79.1.ebuild
@@ -0,0 +1,81 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DOCBOOKDIR="/usr/share/sgml/${PN/-//}"
+MY_PN="${PN%-stylesheets}"
+MY_P="${MY_PN}-${PV}"
+
+DESCRIPTION="XSL Stylesheets for Docbook"
+HOMEPAGE="http://wiki.docbook.org/DocBookXslStylesheets"
+SRC_URI="mirror://sourceforge/docbook/${MY_P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~amd64-fbsd ~sparc-fbsd ~x86-fbsd ~x64-freebsd ~x86-freebsd ~ia64-hpux ~x86-interix ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="ruby"
+
+RDEPEND=">=app-text/build-docbook-catalog-1.1
+ruby? ( || ( dev-lang/ruby:2.0 dev-lang/ruby:2.1 dev-lang/ruby:2.2 ) )"
+DEPEND=""
+
+S="${WORKDIR}/${MY_P}"
+
+# Makefile is broken since 1.76.0
+RESTRICT=test
+
+# The makefile runs tests, not builds.
+src_compile() { :; }
+
+src_test() {
+ emake check
+}
+
+src_install() {
+ # The changelog is now zipped, and copied as the RELEASE-NOTES, so we
+ # don't need to install it
+ dodoc AUTHORS BUGS NEWS README RELEASE-NOTES.txt TODO
+
+ insinto ${DOCBOOKDIR}
+ doins VERSION VERSION.xsl
+
+ local i
+ for i in $(find . -maxdepth 1 -mindepth 1 -type d -exec basename {} \;); do
+ [[ "$i" == "epub" ]] && ! use ruby && continue
+
+ cd "${S}"/${i}
+ for doc in ChangeLog README; do
+ if [ -e "$doc" ]; then
+ mv ${doc} ${doc}.${i}
+ dodoc ${doc}.${i}
+ rm ${doc}.${i}
+ fi
+ done
+
+ doins -r "${S}"/${i}
+ done
+
+ if use ruby; then
+ local cmd="dbtoepub${MY_PN#docbook-xsl}"
+
+ # we can't use a symlink or it'll look for the library in the
+ # wrong path.
+ dodir /usr/bin
+ cat - > "${D}"/usr/bin/${cmd} <<EOF
+#!/usr/bin/env ruby
+
+load "${DOCBOOKDIR}/epub/bin/dbtoepub"
+EOF
+ fperms 0755 /usr/bin/${cmd}
+ fi
+}
+
+pkg_postinst() {
+ build-docbook-catalog
+}
+
+pkg_postrm() {
+ build-docbook-catalog
+}