summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Weber <xmw@gentoo.org>2018-01-28 16:55:42 +0100
committerMichael Weber <xmw@gentoo.org>2018-01-28 17:18:57 +0100
commit825ed23abcfe8e59e959abbece8a95c8d05cc57f (patch)
tree4b44dea062015ed7e7ec9e289ffce4691ac70a83 /app-text
parentdev-libs/girara: Version bump. (diff)
downloadgentoo-825ed23abcfe8e59e959abbece8a95c8d05cc57f.tar.gz
gentoo-825ed23abcfe8e59e959abbece8a95c8d05cc57f.tar.bz2
gentoo-825ed23abcfe8e59e959abbece8a95c8d05cc57f.zip
app-text/zathura-cb: Version bump.
Package-Manager: Portage-2.3.20, Repoman-2.3.6
Diffstat (limited to 'app-text')
-rw-r--r--app-text/zathura-cb/Manifest1
-rw-r--r--app-text/zathura-cb/zathura-cb-0.1.7.ebuild58
-rw-r--r--app-text/zathura-cb/zathura-cb-9999.ebuild9
3 files changed, 64 insertions, 4 deletions
diff --git a/app-text/zathura-cb/Manifest b/app-text/zathura-cb/Manifest
index cf489bfc97fe..e94b2abb64dc 100644
--- a/app-text/zathura-cb/Manifest
+++ b/app-text/zathura-cb/Manifest
@@ -1 +1,2 @@
DIST zathura-cb-0.1.6.tar.gz 7205 BLAKE2B 57fa7c8d54cdfdd717d89b8341139c70c86921a65b328a59f1e382d4c8ea03c041184f065e092ec98fff577c029363430b32db95a3b034cbeb19eb51b07d3948 SHA512 986293957b6bc5e5fe7033bb7c91e857b1089fe1a041eb39e516b4e906c2619d22d7ebfa0bfaba982cc6145cba4c6a2af01be810c6da71f4c862fb42bc91f230
+DIST zathura-cb-0.1.7.tar.gz 6971 BLAKE2B 814b0ff8e3d33c85e06ceb3abb315aa16464efda8a5c60554eb7ac8ce3babcf33daea5122e1ca201c1fbffb616a1eea79ba40b74e0c325ec23a7c2dd249d2e6f SHA512 a48c70bf534a8798d94c1b15382dad229d37ea5f5cbef8382ce87a4366c3607609577f10a8eeb2056e2aa539014e6411e08c879f5359f80ff676cb55c6ae9af2
diff --git a/app-text/zathura-cb/zathura-cb-0.1.7.ebuild b/app-text/zathura-cb/zathura-cb-0.1.7.ebuild
new file mode 100644
index 000000000000..4c3f58bbc0cf
--- /dev/null
+++ b/app-text/zathura-cb/zathura-cb-0.1.7.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils toolchain-funcs readme.gentoo-r1 xdg
+
+if [[ ${PV} == *9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://git.pwmt.org/pwmt/zathura-cb.git"
+ EGIT_BRANCH="develop"
+else
+ KEYWORDS="~amd64 ~arm ~x86"
+ SRC_URI="http://pwmt.org/projects/zathura/plugins/download/${P}.tar.gz"
+fi
+
+DESCRIPTION="Comic book plug-in for zathura with 7zip, rar, tar and zip support"
+HOMEPAGE="http://pwmt.org/projects/zathura/"
+
+LICENSE="ZLIB"
+SLOT="0"
+IUSE=""
+
+RDEPEND=">=app-text/zathura-0.3.8
+ dev-libs/glib:2=
+ app-arch/libarchive:=
+ x11-libs/cairo:=
+ x11-libs/gdk-pixbuf:="
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_configure() {
+ myzathuraconf=(
+ CC="$(tc-getCC)"
+ LD="$(tc-getLD)"
+ VERBOSE=1
+ DESTDIR="${D}"
+ )
+}
+
+src_compile() {
+ emake "${myzathuraconf[@]}"
+}
+
+src_install() {
+ emake "${myzathuraconf[@]}" install
+ dodoc AUTHORS
+
+ FORCE_PRINT_ELOG=1
+ local DOC_CONTENTS="Consider installing app-arch/p7zip app-arch/tar app-arch/unrar
+ app-arch/unzip for additional file support."
+ readme.gentoo_create_doc
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ readme.gentoo_print_elog
+}
diff --git a/app-text/zathura-cb/zathura-cb-9999.ebuild b/app-text/zathura-cb/zathura-cb-9999.ebuild
index 32698cdd593e..4c3f58bbc0cf 100644
--- a/app-text/zathura-cb/zathura-cb-9999.ebuild
+++ b/app-text/zathura-cb/zathura-cb-9999.ebuild
@@ -1,9 +1,9 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
+EAPI=6
-inherit eutils toolchain-funcs readme.gentoo-r1
+inherit eutils toolchain-funcs readme.gentoo-r1 xdg
if [[ ${PV} == *9999 ]]; then
inherit git-r3
@@ -21,7 +21,7 @@ LICENSE="ZLIB"
SLOT="0"
IUSE=""
-RDEPEND=">=app-text/zathura-0.3.1
+RDEPEND=">=app-text/zathura-0.3.8
dev-libs/glib:2=
app-arch/libarchive:=
x11-libs/cairo:=
@@ -53,5 +53,6 @@ src_install() {
}
pkg_postinst() {
+ xdg_pkg_postinst
readme.gentoo_print_elog
}