summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2023-01-30 07:51:36 -0600
committerBen Kohler <bkohler@gentoo.org>2023-01-30 07:55:33 -0600
commit8b553eec6e427d6fed25510e1b929d3ed8372a48 (patch)
tree5c68f554ab1f2baa775c08d123468524b86668ba /app-text
parentwww-apps/moodle: drop 3.9.17 (diff)
downloadgentoo-8b553eec6e427d6fed25510e1b929d3ed8372a48.tar.gz
gentoo-8b553eec6e427d6fed25510e1b929d3ed8372a48.tar.bz2
gentoo-8b553eec6e427d6fed25510e1b929d3ed8372a48.zip
app-text/discount: add 3.0.0a_p20230126
Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-3.0.0a_p20230126.ebuild70
2 files changed, 71 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 2ff69b8cde91..da94eb783643 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1 +1,2 @@
DIST discount-2.2.7b.tar.bz2 102685 BLAKE2B 1af4d47248e4a65ea1517b03d0b1a0b15eb79bdb7d1f00779515e2a1113b2a923f5d9e5d0a93d63cfc6c7257f11d3825d9baa55c7f2252fe3d2513785ab67ae3 SHA512 d68ffb85ae3e6d6ce8a2e506609bd4cb042617e350d113dd632a1ed81adb0b076df75ca4e70e97d43f3a3a2907555a9f28087a3762f41806289c526af3c55806
+DIST discount-3.0.0a_p20230126.tar.gz 140311 BLAKE2B 26858c25506dfd68f20d988ca425c0153887bae9574fa3b90b36bc97d90d78e58a4e43cc08ec4a91382015ec7f9e605eb743e98353a8029adcfad5ffb63c948e SHA512 888fc6fd530d1ae970d9b376243f2628113bce847855cfb595a174f7cb6f1bdb55939f686cc65b3b6e3ed4aa1a9b54db77c2c842e4b045ffb69304eb39a15899
diff --git a/app-text/discount/discount-3.0.0a_p20230126.ebuild b/app-text/discount/discount-3.0.0a_p20230126.ebuild
new file mode 100644
index 000000000000..511c1685a741
--- /dev/null
+++ b/app-text/discount/discount-3.0.0a_p20230126.ebuild
@@ -0,0 +1,70 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+COMMIT=5d13c2828da3567210b370bfd8555fdcf01d70bd
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="https://github.com/Orc/discount/archive/${COMMIT}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD"
+SLOT="0/3.0.0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~riscv ~sparc ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+S="${WORKDIR}/${PN}-${COMMIT}"
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --prefix="${EPREFIX}/usr"
+ --mandir="${EPREFIX}/usr/share/man"
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}