summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2020-08-14 12:04:28 +0200
committerJeroen Roovers <jer@gentoo.org>2020-08-14 12:08:51 +0200
commit8e1c3c9177201436f99353384bfd73c66d79299e (patch)
tree51c43b7b3fdb591ebe40097cbeda751fd8c8f03d /app-text
parentapp-text/glosung: Remove last-rited package (diff)
downloadgentoo-8e1c3c9177201436f99353384bfd73c66d79299e.tar.gz
gentoo-8e1c3c9177201436f99353384bfd73c66d79299e.tar.bz2
gentoo-8e1c3c9177201436f99353384bfd73c66d79299e.zip
app-text/sablotron: Format sabcmd.cpp for C++11 compatibility
While there: - Add IUSE=static-libs and remove .la files - Clean up patch - EAPI=7 - Replace defunct HOMEPAGE/SRC_URI Package-Manager: Portage-3.0.2, Repoman-2.3.23 Closes: https://bugs.gentoo.org/show_bug.cgi?id=726732 Closes: https://bugs.gentoo.org/show_bug.cgi?id=729590 Signed-off-by: Jeroen Roovers <jer@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/sablotron/files/1.0.3-cxx11.patch11
-rw-r--r--app-text/sablotron/files/1.0.3-libsablot-expat.patch2
-rw-r--r--app-text/sablotron/sablotron-1.0.3-r2.ebuild55
3 files changed, 66 insertions, 2 deletions
diff --git a/app-text/sablotron/files/1.0.3-cxx11.patch b/app-text/sablotron/files/1.0.3-cxx11.patch
new file mode 100644
index 000000000000..edc1e3141d94
--- /dev/null
+++ b/app-text/sablotron/files/1.0.3-cxx11.patch
@@ -0,0 +1,11 @@
+--- a/src/command/sabcmd.cpp
++++ b/src/command/sabcmd.cpp
+@@ -168,7 +168,7 @@
+
+ char askhelp[] = "Type sabcmd --help to display a help message.\n";
+ char msgConflict[] = "conflict with preceding switches: ";
+-char version_txt[] = "\nsabcmd "SAB_VERSION" ("SAB_DATE")\n"\
++char version_txt[] = "\nsabcmd " SAB_VERSION " (" SAB_DATE ")\n"\
+ "copyright (C) 2000 - 2005 Ginger Alliance (www.gingerall.com)\n";
+ char dbg_usage[] = "\nDebugging options:\n"\
+ "\t--debug\t\t\tdisplay results of the command line parse\n"\
diff --git a/app-text/sablotron/files/1.0.3-libsablot-expat.patch b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
index 328c9e906856..e4f6c3fdfab3 100644
--- a/app-text/sablotron/files/1.0.3-libsablot-expat.patch
+++ b/app-text/sablotron/files/1.0.3-libsablot-expat.patch
@@ -1,5 +1,3 @@
-diff --git a/src/engine/Makefile.am b/src/engine/Makefile.am
-index abd2041..1307b1c 100644
--- a/src/engine/Makefile.am
+++ b/src/engine/Makefile.am
@@ -76,4 +76,5 @@ include_HEADERS = \
diff --git a/app-text/sablotron/sablotron-1.0.3-r2.ebuild b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
new file mode 100644
index 000000000000..3d8288a19d60
--- /dev/null
+++ b/app-text/sablotron/sablotron-1.0.3-r2.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools
+
+MY_PN="Sablot"
+MY_P="${MY_PN}-${PV}"
+S=${WORKDIR}/${MY_P}
+
+DESCRIPTION="An XSLT Parser in C++"
+HOMEPAGE="https://sourceforge.net/projects/sablotron/"
+SRC_URI="mirror://sourceforge/sablotron/${MY_P}.tar.gz"
+
+# Sablotron can optionally be built under GPL, using MPL for now
+LICENSE="MPL-1.1"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="perl static-libs"
+
+RDEPEND="
+ >=dev-libs/expat-1.95.6-r1
+"
+DEPEND="
+ ${RDEPEND}
+"
+BDEPEND="
+ >=dev-perl/XML-Parser-2.3
+"
+DOCS=(
+ README README_JS RELEASE src/TODO
+)
+PATCHES=(
+ "${FILESDIR}"/1.0.3-libsablot-expat.patch
+ "${FILESDIR}"/1.0.3-cxx11.patch
+)
+
+src_prepare() {
+ default
+ sed -i configure.in -e 's|AM_CONFIG_HEADER|AC_CONFIG_HEADERS|g' || die
+ eautoreconf
+ elibtoolize
+}
+
+src_configure() {
+ econf \
+ $(use_enable perl perlconnect) \
+ $(use_enable static-libs static) \
+ --with-html-dir="${EPREFIX}"/usr/share/doc/${PF}/html
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -delete || die
+}