summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-08-28 15:03:25 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2022-08-28 15:05:46 +0200
commit96a4aa33cb8bce42aa620ea5cdf65e5f73dd7b9e (patch)
treee9fb5407f6ca991085c3954384d01437ad513d69 /app-text
parentdev-java/gradle-bin: stabilize 7.5 for amd64, x86 (diff)
downloadgentoo-96a4aa33cb8bce42aa620ea5cdf65e5f73dd7b9e.tar.gz
gentoo-96a4aa33cb8bce42aa620ea5cdf65e5f73dd7b9e.tar.bz2
gentoo-96a4aa33cb8bce42aa620ea5cdf65e5f73dd7b9e.zip
app-text/kjots: Fix build with >=akonadi-22.08.0
Upstream commit 85121754c862417e872048ae2f85e9b9fe2ddc7a Closes: https://bugs.gentoo.org/867082 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kjots/files/kjots-5.1.0-akonadi-22.08.0.patch47
-rw-r--r--app-text/kjots/kjots-5.1.0-r2.ebuild1
2 files changed, 48 insertions, 0 deletions
diff --git a/app-text/kjots/files/kjots-5.1.0-akonadi-22.08.0.patch b/app-text/kjots/files/kjots-5.1.0-akonadi-22.08.0.patch
new file mode 100644
index 000000000000..fc5240105b02
--- /dev/null
+++ b/app-text/kjots/files/kjots-5.1.0-akonadi-22.08.0.patch
@@ -0,0 +1,47 @@
+From 85121754c862417e872048ae2f85e9b9fe2ddc7a Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Thu, 14 Jul 2022 14:27:55 +0200
+Subject: [PATCH] Adapt to new KontactInterface::Plugin ctor
+
+---
+ src/kontact_plugin/kjots_plugin.cpp | 5 +++++
+ src/kontact_plugin/kjots_plugin.h | 4 ++++
+ 2 files changed, 9 insertions(+)
+
+diff --git a/src/kontact_plugin/kjots_plugin.cpp b/src/kontact_plugin/kjots_plugin.cpp
+index 1146ab3..c75faac 100644
+--- a/src/kontact_plugin/kjots_plugin.cpp
++++ b/src/kontact_plugin/kjots_plugin.cpp
+@@ -40,8 +40,13 @@
+
+ EXPORT_KONTACT_PLUGIN_WITH_JSON(KJotsPlugin, "kjotsplugin.json")
+
++#if KONTACTINTERFACE_VERSION >= QT_VERSION_CHECK(5, 20, 41)
++KJotsPlugin::KJotsPlugin(KontactInterface::Core *core, const KPluginMetaData &md, const QVariantList &/*args*/)
++ : KontactInterface::Plugin(core, core, md, "kjots")
++#else
+ KJotsPlugin::KJotsPlugin(KontactInterface::Core *core, const QVariantList &/*args*/)
+ : KontactInterface::Plugin(core, core, "kjots")
++#endif
+ {
+ setComponentName(QStringLiteral("kjots"), i18n("KJots"));
+
+diff --git a/src/kontact_plugin/kjots_plugin.h b/src/kontact_plugin/kjots_plugin.h
+index 28a793b..03ff500 100644
+--- a/src/kontact_plugin/kjots_plugin.h
++++ b/src/kontact_plugin/kjots_plugin.h
+@@ -34,7 +34,11 @@ class KJotsPlugin : public KontactInterface::Plugin
+ Q_OBJECT
+
+ public:
++#if KONTACTINTERFACE_VERSION >= QT_VERSION_CHECK(5, 20, 41)
++ KJotsPlugin(KontactInterface::Core *core, const KPluginMetaData &md, const QVariantList &);
++#else
+ KJotsPlugin(KontactInterface::Core *core, const QVariantList &);
++#endif
+
+ int weight() const override
+ {
+--
+GitLab
+
diff --git a/app-text/kjots/kjots-5.1.0-r2.ebuild b/app-text/kjots/kjots-5.1.0-r2.ebuild
index 7ef5fe968253..ade68829883b 100644
--- a/app-text/kjots/kjots-5.1.0-r2.ebuild
+++ b/app-text/kjots/kjots-5.1.0-r2.ebuild
@@ -52,4 +52,5 @@ PATCHES=(
"${FILESDIR}/${P}-akonadi-21.12.0.patch" # bug 830580
"${FILESDIR}/${P}-speech-optional.patch" # bug 835128
"${FILESDIR}/${P}-akonadi-22.04.0.patch" # bug 840272
+ "${FILESDIR}/${P}-akonadi-22.08.0.patch" # bug 867082
)