summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2020-04-04 03:02:23 +0200
committerAndreas Sturmlechner <asturm@gentoo.org>2020-04-04 03:02:23 +0200
commit9758d2c54ef74f92cca50c091055bfaba694e085 (patch)
treeed9f11ed4a98d20b724d306316d5d3453b15f51e /app-text
parentdev-python/pysol_cards: Drop 0.8.8 (diff)
downloadgentoo-9758d2c54ef74f92cca50c091055bfaba694e085.tar.gz
gentoo-9758d2c54ef74f92cca50c091055bfaba694e085.tar.bz2
gentoo-9758d2c54ef74f92cca50c091055bfaba694e085.zip
app-text/libmwaw: 0.3.16 version bump
Package-Manager: Portage-2.3.96, Repoman-2.3.22 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/libmwaw/Manifest1
-rw-r--r--app-text/libmwaw/libmwaw-0.3.16.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/libmwaw/Manifest b/app-text/libmwaw/Manifest
index c569172748d7..41b0a163fe23 100644
--- a/app-text/libmwaw/Manifest
+++ b/app-text/libmwaw/Manifest
@@ -1 +1,2 @@
DIST libmwaw-0.3.15.tar.xz 1289744 BLAKE2B 9aed923542e795904761e4969299785906aa65c735541788d91eb41e80420ac6c6df4df5e0cfa156c71d4e100c601e5e984de10c6a5f66eebe6ffb5f0374cc1d SHA512 0b2443fc6bc9da9247f7585743424df440f89317af989018d8b972864bf91e3c5cd78c39094a45d9de8114906b2b2a93f68ddb967af8565e4b499f643d86e682
+DIST libmwaw-0.3.16.tar.xz 1306872 BLAKE2B 29c39ddb2cfe63116cbe7152a4dc3b7f16d402745c0dffd67c07dc42fa1ddee71f391695ead2519b3e1da206e8f437fbd24fa78ce1decfaa55e38a13d5d144e8 SHA512 c043d77e4b0efd7da594c1e370f24ee2d85afcb8a5e28179b4c3d76c8b7925f41ca5361bee12b35af732ef39f34fac46aa3636cb27c179ef9bb2b6feeaa19b0a
diff --git a/app-text/libmwaw/libmwaw-0.3.16.ebuild b/app-text/libmwaw/libmwaw-0.3.16.ebuild
new file mode 100644
index 000000000000..f4561cebf565
--- /dev/null
+++ b/app-text/libmwaw/libmwaw-0.3.16.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+if [[ ${PV} = 9999 ]]; then
+ EGIT_REPO_URI="https://git.code.sf.net/p/libmwaw/libmwaw"
+ inherit autotools git-r3
+else
+ SRC_URI="mirror://sourceforge/${PN}/${P}.tar.xz"
+ KEYWORDS="~amd64 ~arm ~arm64 ~ppc64 ~x86"
+fi
+
+DESCRIPTION="Library parsing many pre-OSX MAC text formats"
+HOMEPAGE="https://sourceforge.net/p/libmwaw/wiki/Home/"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+IUSE="doc static-libs tools"
+
+BDEPEND="
+ sys-devel/libtool
+ virtual/pkgconfig
+ doc? ( app-doc/doxygen )
+"
+DEPEND="
+ dev-libs/librevenge
+ sys-libs/zlib
+"
+RDEPEND="${DEPEND}"
+
+src_prepare() {
+ default
+ [[ ${PV} == 9999 ]] && eautoreconf
+}
+
+src_configure() {
+ # zip is hard enabled as the zlib is dep on the rdeps anyway
+ local myeconfargs=(
+ --enable-zip
+ --disable-werror
+ $(use_with doc docs)
+ $(use_enable static-libs static)
+ $(use_enable tools)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -type f -delete || die
+}