summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatt Turner <mattst88@gentoo.org>2019-09-19 22:45:01 -0700
committerMatt Turner <mattst88@gentoo.org>2019-10-21 12:51:03 -0700
commit990ab38ba6b7959caba4cc5648158423628d2bf3 (patch)
tree6103a092b79313070f035e3cf1b2626cb027c2ba /app-text
parentapp-accessibility/at-spi2-atk: Version bump to 2.34.0 (diff)
downloadgentoo-990ab38ba6b7959caba4cc5648158423628d2bf3.tar.gz
gentoo-990ab38ba6b7959caba4cc5648158423628d2bf3.tar.bz2
gentoo-990ab38ba6b7959caba4cc5648158423628d2bf3.zip
app-text/gspell: Version bump to 1.8.2
* sys-devel/gettext dependency raised to 0.19.6 Signed-off-by: Matt Turner <mattst88@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/gspell/Manifest1
-rw-r--r--app-text/gspell/gspell-1.8.2.ebuild48
2 files changed, 49 insertions, 0 deletions
diff --git a/app-text/gspell/Manifest b/app-text/gspell/Manifest
index e517025f3b5d..24f1d62f0546 100644
--- a/app-text/gspell/Manifest
+++ b/app-text/gspell/Manifest
@@ -1,2 +1,3 @@
DIST gspell-1.6.1.tar.xz 416704 BLAKE2B 2a180bc52d3f09813d8de362e5bf900f831663c09530c8a9b993baf55f852a3939447a71c9c9dc0caafba7e8b74a2a5aad4443cf248eb87da4e15e0481e74262 SHA512 f1ffbd0d23d9743bcf924c25b3a3d7bf93c6a5e4ea5e362fb7300f657d8c1d0117e847f3dec29de377947f850e003b24a3231e88e99b313c955dd94ce358c23e
DIST gspell-1.8.1.tar.xz 419268 BLAKE2B f32c9c518c23f8f560d65eb6fb122703561cc09e385eefa99d0761e8aa5b5bf3a8cec3cab7071043134314262979de56d08ee2929973b7968016b123e53d8f16 SHA512 ae94f46c7bdcdeefa0279cd4ac3c50e53b63092016e298ef6b502c40c2574a2135c503ab322f5a3a7b8b4422fdec291a6ed0c937683a8c0f32d7ad474cc1569b
+DIST gspell-1.8.2.tar.xz 421936 BLAKE2B 5fdff772e716c1f062002d7371064dbbaf6eb43e77cef03b8fca7ea71a91eac82ca54a5463c0f785153a15ceb65ad06aeecc069196765cb78e5dfaff5d81fec6 SHA512 220bdec2b8229e848960e5e31bda1209dedac232637d3e6d4931ca2552054fbdf3f576d52f3d5a7ac734e6e626f2fcc7cefd0bff906b29ba9930cef791906c32
diff --git a/app-text/gspell/gspell-1.8.2.ebuild b/app-text/gspell/gspell-1.8.2.ebuild
new file mode 100644
index 000000000000..19aaa905998b
--- /dev/null
+++ b/app-text/gspell/gspell-1.8.2.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="6"
+VALA_USE_DEPEND="vapigen"
+
+inherit gnome2 vala virtualx
+
+DESCRIPTION="Spell check library for GTK+ applications"
+HOMEPAGE="https://wiki.gnome.org/Projects/gspell"
+
+LICENSE="LGPL-2.1+"
+SLOT="0/1" # subslot = libgspell-1 soname version
+KEYWORDS="~alpha ~amd64 ~arm ~ppc ~ppc64 ~sparc ~x86 ~amd64-fbsd"
+
+IUSE="+introspection vala"
+REQUIRED_USE="vala? ( introspection )"
+
+RDEPEND="
+ app-text/iso-codes
+ >=app-text/enchant-2.1.3
+ >=dev-libs/glib-2.44:2
+ >=x11-libs/gtk+-3.20:3[introspection?]
+ introspection? ( >=dev-libs/gobject-introspection-1.42.0:= )
+ vala? ( $(vala_depend) )
+"
+DEPEND="${RDEPEND}
+ dev-libs/libxml2:2
+ dev-util/glib-utils
+ >=dev-util/gtk-doc-am-1.25
+ >=sys-devel/gettext-0.19.6
+ virtual/pkgconfig
+"
+
+src_prepare() {
+ use vala && vala_src_prepare
+ gnome2_src_prepare
+}
+
+src_configure() {
+ gnome2_src_configure \
+ $(use_enable introspection) \
+ $(use_enable vala)
+}
+
+src_test() {
+ virtx emake check
+}