summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 13:17:22 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-07 14:46:36 +0100
commit9d5ceb8565f0ef389547136ad88ff8bb632d7dc7 (patch)
treed3946a55b256556b69235f49995e88ef439171a5 /app-text
parentapp-text/poppler: Bump subslot (diff)
downloadgentoo-9d5ceb8565f0ef389547136ad88ff8bb632d7dc7.tar.gz
gentoo-9d5ceb8565f0ef389547136ad88ff8bb632d7dc7.tar.bz2
gentoo-9d5ceb8565f0ef389547136ad88ff8bb632d7dc7.zip
app-text/poppler: 22.01.0 version bump
Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/poppler/Manifest1
-rw-r--r--app-text/poppler/poppler-22.01.0.ebuild126
2 files changed, 127 insertions, 0 deletions
diff --git a/app-text/poppler/Manifest b/app-text/poppler/Manifest
index 57c9775695f0..c34c5d4a2099 100644
--- a/app-text/poppler/Manifest
+++ b/app-text/poppler/Manifest
@@ -1,2 +1,3 @@
DIST poppler-21.11.0.tar.xz 1783592 BLAKE2B b0448ae0456ffda29c18732e6dd94cb285af67cf4adbaded05a4abe2e465cb63a17e0041240c82c83c89b313ec8c7bf9d68fc8d727b7d41c1ee70722529ce45d SHA512 354d6372093e7ecedf95c43e8d203e9b2781ff7ecd81cd3920cb8c72a37463b47423ce7ab3c8233c0f031f2c024ac1ba5c8d442c80e6643722192fb9638e5d3a
DIST poppler-21.12.0.tar.xz 1798780 BLAKE2B 403f928dfe8f94048307eb120dcd85c9821a12e100b7030831864fbc630244e79923e48061352e49e1a6daf5eda7f05b32254735ef5037db108ac4e3fedd877e SHA512 86856e33479a357deb671b4fdd6336a7581b5ac14b9715ffc2482d8dba7a455aab07317b1fc0c33f479f11de38012958fffa619105c255de51929e61a6b63e33
+DIST poppler-22.01.0.tar.xz 1801984 BLAKE2B f238636a0b1f07e0b70de99d8f0b3afcb7e2424c9dee4a044edaa5bd34753061e58a7c530792264ffb5a520cb4dc7dc52de17573fda350de97bef6346048fb76 SHA512 c6ea908a9188483ca588ac81d3e92dd15a405f90d36cc7059e618c8a7e3e9faeda82717aba5df34adb4a0a94e2fbecd472acec44972272349cc8d5a57b7405d1
diff --git a/app-text/poppler/poppler-22.01.0.ebuild b/app-text/poppler/poppler-22.01.0.ebuild
new file mode 100644
index 000000000000..bd261ab8e292
--- /dev/null
+++ b/app-text/poppler/poppler-22.01.0.ebuild
@@ -0,0 +1,126 @@
+# Copyright 2005-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit cmake toolchain-funcs xdg-utils
+
+if [[ ${PV} == *9999* ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://anongit.freedesktop.org/git/poppler/poppler.git"
+ SLOT="0/9999"
+else
+ SRC_URI="https://poppler.freedesktop.org/${P}.tar.xz"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+ SLOT="0/117" # CHECK THIS WHEN BUMPING!!! SUBSLOT IS libpoppler.so SOVERSION
+fi
+
+DESCRIPTION="PDF rendering library based on the xpdf-3.0 code base"
+HOMEPAGE="https://poppler.freedesktop.org/"
+
+LICENSE="GPL-2"
+IUSE="boost cairo cjk curl +cxx debug doc +introspection +jpeg +jpeg2k +lcms nss png qt5 tiff +utils"
+
+# No test data provided
+RESTRICT="test"
+
+DEPEND="
+ media-libs/fontconfig
+ media-libs/freetype
+ sys-libs/zlib
+ cairo? (
+ dev-libs/glib:2
+ x11-libs/cairo
+ introspection? ( dev-libs/gobject-introspection:= )
+ )
+ curl? ( net-misc/curl )
+ jpeg? ( virtual/jpeg:0 )
+ jpeg2k? ( >=media-libs/openjpeg-2.3.0-r1:2= )
+ lcms? ( media-libs/lcms:2 )
+ nss? ( >=dev-libs/nss-3.19:0 )
+ png? ( media-libs/libpng:0= )
+ qt5? (
+ dev-qt/qtcore:5
+ dev-qt/qtgui:5
+ dev-qt/qtxml:5
+ )
+ tiff? ( media-libs/tiff:0 )
+"
+RDEPEND="${DEPEND}
+ cjk? ( app-text/poppler-data )
+"
+DEPEND+="
+ boost? ( dev-libs/boost )
+"
+BDEPEND="
+ dev-util/glib-utils
+ virtual/pkgconfig
+"
+
+DOCS=( AUTHORS NEWS README.md README-XPDF )
+
+PATCHES=(
+ "${FILESDIR}/${PN}-20.12.1-qt5-deps.patch"
+ "${FILESDIR}/${PN}-21.09.0-respect-cflags.patch"
+ "${FILESDIR}/${PN}-0.57.0-disable-internal-jpx.patch"
+)
+
+src_prepare() {
+ cmake_src_prepare
+
+ # Clang doesn't grok this flag, the configure nicely tests that, but
+ # cmake just uses it, so remove it if we use clang
+ if tc-is-clang ; then
+ sed -e 's/-fno-check-new//' -i cmake/modules/PopplerMacros.cmake || die
+ fi
+
+ if ! grep -Fq 'cmake_policy(SET CMP0002 OLD)' CMakeLists.txt ; then
+ sed -e '/^cmake_minimum_required/acmake_policy(SET CMP0002 OLD)' \
+ -i CMakeLists.txt || die
+ else
+ einfo "policy(SET CMP0002 OLD) - workaround can be removed"
+ fi
+}
+
+src_configure() {
+ xdg_environment_reset
+ local mycmakeargs=(
+ -DBUILD_GTK_TESTS=OFF
+ -DBUILD_QT5_TESTS=OFF
+ -DBUILD_CPP_TESTS=OFF
+ -DBUILD_MANUAL_TESTS=OFF
+ -DRUN_GPERF_IF_PRESENT=OFF
+ -DENABLE_BOOST="$(usex boost)"
+ -DENABLE_ZLIB=ON
+ -DENABLE_ZLIB_UNCOMPRESS=OFF
+ -DENABLE_UNSTABLE_API_ABI_HEADERS=ON
+ -DUSE_FLOAT=OFF
+ -DWITH_Cairo=$(usex cairo)
+ -DENABLE_LIBCURL=$(usex curl)
+ -DENABLE_CPP=$(usex cxx)
+ -DWITH_JPEG=$(usex jpeg)
+ -DENABLE_DCTDECODER=$(usex jpeg libjpeg none)
+ -DENABLE_LIBOPENJPEG=$(usex jpeg2k openjpeg2 none)
+ -DENABLE_CMS=$(usex lcms lcms2 none)
+ -DWITH_NSS3=$(usex nss)
+ -DWITH_PNG=$(usex png)
+ $(cmake_use_find_package qt5 Qt5Core)
+ -DWITH_TIFF=$(usex tiff)
+ -DENABLE_UTILS=$(usex utils)
+ -DENABLE_QT6=OFF
+ )
+ use cairo && mycmakeargs+=( -DWITH_GObjectIntrospection=$(usex introspection) )
+
+ cmake_src_configure
+}
+
+src_install() {
+ cmake_src_install
+
+ # live version doesn't provide html documentation
+ if use cairo && use doc && [[ ${PV} != *9999* ]]; then
+ # For now install gtk-doc there
+ insinto /usr/share/gtk-doc/html/poppler
+ doins -r "${S}"/glib/reference/html/*
+ fi
+}