summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndrey Grozin <grozin@gentoo.org>2020-07-20 21:33:50 +0700
committerAndrey Grozin <grozin@gentoo.org>2020-07-20 22:16:08 +0700
commitafda95927ec161b2ddee8e08839426a811260cff (patch)
treebe63cafc2b9e652777b292ed6c90ca8528e30106 /app-text
parentdev-python/hcloud-python: remove old for dev-python/requests cleanup (diff)
downloadgentoo-afda95927ec161b2ddee8e08839426a811260cff.tar.gz
gentoo-afda95927ec161b2ddee8e08839426a811260cff.tar.bz2
gentoo-afda95927ec161b2ddee8e08839426a811260cff.zip
app-text/foliate: correct dependencies
Closes: https://bugs.gentoo.org/732366 Package-Manager: Portage-3.0.0, Repoman-2.3.23 Signed-off-by: Andrey Grozin <grozin@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/foliate/foliate-2.4.2-r1.ebuild51
-rw-r--r--app-text/foliate/metadata.xml3
2 files changed, 54 insertions, 0 deletions
diff --git a/app-text/foliate/foliate-2.4.2-r1.ebuild b/app-text/foliate/foliate-2.4.2-r1.ebuild
new file mode 100644
index 000000000000..6a96690330e9
--- /dev/null
+++ b/app-text/foliate/foliate-2.4.2-r1.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+PLOCALES="cs_CS de_DE es fr_FR id_ID ie it nl pt_BR ru_RU sv tr uk zh_CN zh_TW"
+inherit meson l10n xdg-utils gnome2-utils
+SRC_URI="https://github.com/johnfactotum/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+DESCRIPTION="gtk ebook reader built with gjs"
+HOMEPAGE="https://github.com/johnfactotum/foliate/"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="handy spell"
+
+BDEPEND="${MESON_DEPEND}
+ sys-devel/gettext"
+RDEPEND="dev-libs/gjs
+ x11-libs/gtk+:3[introspection]
+ x11-libs/pango[introspection]
+ x11-libs/gdk-pixbuf:2[introspection]
+ net-libs/webkit-gtk:4[introspection]
+ handy? ( gui-libs/libhandy:=[introspection] )
+ spell? ( app-text/gspell[introspection] )"
+
+src_prepare() {
+ default
+
+ l10n_find_plocales_changes "${S}"/po '' '.po'
+
+ rm_po() {
+ rm po/${1}.po
+ sed -e "/^${1}/d" -i po/LINGUAS
+ }
+
+ l10n_for_each_disabled_locale_do rm_po
+}
+
+pkg_postinst() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
+
+pkg_postrm() {
+ xdg_desktop_database_update
+ xdg_mimeinfo_database_update
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}
diff --git a/app-text/foliate/metadata.xml b/app-text/foliate/metadata.xml
index 61acad2b9559..7c05fa08f38b 100644
--- a/app-text/foliate/metadata.xml
+++ b/app-text/foliate/metadata.xml
@@ -9,6 +9,9 @@
Supported formats:
epub, epub3, azw, azw3, mobi, fb2, fb2.zip, cbr, cbz, cbt, cb7, txt
</longdescription>
+ <use>
+ <flag name="handy">Use <pkg>gui-libs/libhandy</pkg></flag>
+ </use>
<upstream>
<remote-id type="github">johnfactotum/foliate</remote-id>
</upstream>