summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2021-12-29 03:54:15 +0000
committerSam James <sam@gentoo.org>2021-12-29 03:54:46 +0000
commitbb2c3128f92b3cdf119710158e9abc11b113d317 (patch)
tree6431a9c572e4b8a14e2fc031e58d20db25bd2ec2 /app-text
parentapp-text/ocrad: drop project tex (diff)
downloadgentoo-bb2c3128f92b3cdf119710158e9abc11b113d317.tar.gz
gentoo-bb2c3128f92b3cdf119710158e9abc11b113d317.tar.bz2
gentoo-bb2c3128f92b3cdf119710158e9abc11b113d317.zip
app-text/epspdf: add 0.6.5
We'll cut it out of TL 2022, but bump now so things keep working. Bug: https://bugs.gentoo.org/695990 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/epspdf/Manifest1
-rw-r--r--app-text/epspdf/epspdf-0.6.5.ebuild56
2 files changed, 57 insertions, 0 deletions
diff --git a/app-text/epspdf/Manifest b/app-text/epspdf/Manifest
index 01e04f7bbd4c..bc3fef3d9903 100644
--- a/app-text/epspdf/Manifest
+++ b/app-text/epspdf/Manifest
@@ -1 +1,2 @@
+DIST epspdf-0.6.5.zip 331312 BLAKE2B 3bd2c9cd432172c38efe33d08068f20fddf169d5d7bc94c9f1720cf379de9ba54aedb1cb6fd438b721c2e98f24dfd1ca4b3dab5c1fe01a71791748f952832ac9 SHA512 28ef12546a957c62fd94b405b53359898d46c825bad8fd2167b5ab23bb2a6ea457ccbcc8263b31574e128ebe56e21b30fae27d406397df3fdc1506a088ab41f4
DIST epspdf.0.6.3.tgz 335975 BLAKE2B aacd6e222bfe74636dba796fd6e878fa9970f469d096eb77acf4a336a0ab5620629de7ba1c763afa62b181887724db55be57d1929a041a945c7d74ea3028d6de SHA512 ddb0d8c17b6b0bbb934312e6253a2b689d2545c892af989efac9782022c501109f2ff57bb2ea7c26d63d7747e2a510c18bd22a6076bb7137fe0252c38b2125ea
diff --git a/app-text/epspdf/epspdf-0.6.5.ebuild b/app-text/epspdf/epspdf-0.6.5.ebuild
new file mode 100644
index 000000000000..1c46675218c9
--- /dev/null
+++ b/app-text/epspdf/epspdf-0.6.5.ebuild
@@ -0,0 +1,56 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop texlive-common
+
+DESCRIPTION="GUI and command-line converter for [e]ps and pdf"
+HOMEPAGE="http://tex.aanhet.net/epspdf/"
+# http://tex.aanhet.net/epspdf/${PN}.${PV}.tgz
+SRC_URI="https://dev.gentoo.org/~sam/distfiles/${CATEGORY}/${PN}/${P}.zip"
+S="${WORKDIR}"/${PN}
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="doc tk"
+
+RDEPEND="!<dev-texlive/texlive-pictures-2011-r1
+ >=dev-texlive/texlive-basic-2011
+ app-text/ghostscript-gpl
+ tk? ( dev-lang/tk )"
+BDEPEND="app-arch/unzip
+ sys-apps/texinfo"
+
+src_compile() {
+ cd doc || die
+ makeinfo epspdf || die
+}
+
+src_install() {
+ exeinto /usr/share/${PN}
+ doexe epspdf.tlu
+
+ insinto /usr/share/${PN}
+
+ if use tk ; then
+ doins epspdf.help doc/images/epspdf.png
+ doexe epspdftk.tcl
+ fi
+
+ dobin_texmf_scripts ${PN}/epspdf.tlu
+ use tk && dobin_texmf_scripts ${PN}/epspdftk.tcl
+
+ doinfo doc/epspdf.info
+ dodoc doc/Changelog
+ if use doc ; then
+ dodoc doc/epspdf.pdf
+ dodoc -r doc
+ fi
+
+ # Give it a .desktop
+ if use tk; then
+ make_desktop_entry epspdftk epspdftk "${EPREFIX}/usr/share/${PN}/epspdf.png" "Graphics;ImageProcessing"
+ fi
+}