summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMatthias Maier <tamiko@gentoo.org>2021-05-16 13:56:00 -0500
committerMatthias Maier <tamiko@gentoo.org>2021-05-16 13:56:51 -0500
commitbd3eb60f46af56a02a5b11976349009cadbcc083 (patch)
tree04875c188872f05a475d98ed4f49951b1c70dac4 /app-text
parentmedia-libs/libsdl: Stabilize 1.2.15_p20210224 arm, #692388 (diff)
downloadgentoo-bd3eb60f46af56a02a5b11976349009cadbcc083.tar.gz
gentoo-bd3eb60f46af56a02a5b11976349009cadbcc083.tar.bz2
gentoo-bd3eb60f46af56a02a5b11976349009cadbcc083.zip
app-text/barcode: also install static library
Closes: https://bugs.gentoo.org/758491 Package-Manager: Portage-3.0.18, Repoman-3.0.3 RepoMan-Options: --force Signed-off-by: Matthias Maier <tamiko@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/barcode/barcode-0.99-r1.ebuild (renamed from app-text/barcode/barcode-0.99.ebuild)12
-rw-r--r--app-text/barcode/files/barcode-0.99-install-static-lib.patch13
2 files changed, 23 insertions, 2 deletions
diff --git a/app-text/barcode/barcode-0.99.ebuild b/app-text/barcode/barcode-0.99-r1.ebuild
index bd58bc146e16..40c42b4118df 100644
--- a/app-text/barcode/barcode-0.99.ebuild
+++ b/app-text/barcode/barcode-0.99-r1.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2021 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -14,7 +14,11 @@ KEYWORDS="amd64 ~arm ~ppc ~ppc64 x86 ~amd64-linux ~x86-linux ~ppc-macos"
RDEPEND="app-text/libpaper"
DEPEND="${RDEPEND}"
-PATCHES=( "${FILESDIR}"/${P}-fno-common.patch )
+PATCHES=(
+ "${FILESDIR}"/${P}-fno-common.patch
+ "${FILESDIR}"/${P}-install-static-lib.patch
+)
+
src_prepare() {
sed -i -e '/^LDFLAGS =/s:=:+=:' \
@@ -25,3 +29,7 @@ src_prepare() {
default
}
+
+src_configure() {
+ econf --disable-shared
+}
diff --git a/app-text/barcode/files/barcode-0.99-install-static-lib.patch b/app-text/barcode/files/barcode-0.99-install-static-lib.patch
new file mode 100644
index 000000000000..44d32d059ce9
--- /dev/null
+++ b/app-text/barcode/files/barcode-0.99-install-static-lib.patch
@@ -0,0 +1,13 @@
+--- barcode-0.99_orig/Makefile.am 2020-12-06 15:39:43.270943391 +0100
++++ barcode-0.99/Makefile.am 2020-12-06 15:40:26.723942515 +0100
+@@ -25,7 +25,9 @@
+
+ bin_PROGRAMS = barcode sample
+
+-noinst_LTLIBRARIES = libbarcode.la
++lib_LTLIBRARIES = libbarcode.la
++
++include_HEADERS = barcode.h lib/gettext.h
+
+ ACLOCAL_AMFLAGS = -I m4
+