summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorVolkmar W. Pogatzki <gentoo@pogatzki.net>2021-02-22 10:20:27 +0100
committerSam James <sam@gentoo.org>2021-02-27 07:44:46 +0000
commitc05cd4ced17782ad0745c8002d1f921746936912 (patch)
tree1567053fa62f4f84c9f208234009a873e2066405 /app-text
parentnet-analyzer/mbrowse: minor style changes (diff)
downloadgentoo-c05cd4ced17782ad0745c8002d1f921746936912.tar.gz
gentoo-c05cd4ced17782ad0745c8002d1f921746936912.tar.bz2
gentoo-c05cd4ced17782ad0745c8002d1f921746936912.zip
app-text/xmlto: EAPI 7
Adding www-client/links as an alternative to virtual/w3m Closes: https://bugs.gentoo.org/726156 Package-Manager: Portage-3.0.13, Repoman-3.0.2 Signed-off-by: Volkmar W. Pogatzki <gentoo@pogatzki.net> Closes: https://github.com/gentoo/gentoo/pull/19593 Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/xmlto/xmlto-0.0.28-r4.ebuild42
1 files changed, 42 insertions, 0 deletions
diff --git a/app-text/xmlto/xmlto-0.0.28-r4.ebuild b/app-text/xmlto/xmlto-0.0.28-r4.ebuild
new file mode 100644
index 000000000000..0c449e22a848
--- /dev/null
+++ b/app-text/xmlto/xmlto-0.0.28-r4.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="script for converting XML and DocBook documents to a variety of output formats"
+HOMEPAGE="https://pagure.io/xmlto"
+SRC_URI="https://releases.pagure.org/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="latex text"
+
+RDEPEND="app-text/docbook-xsl-stylesheets
+ app-text/docbook-xml-dtd:4.2
+ dev-libs/libxslt
+ || ( sys-apps/util-linux app-misc/getopt )
+ text? ( || ( virtual/w3m www-client/elinks www-client/links www-client/lynx ) )
+ latex? ( dev-texlive/texlive-formatsextra )"
+# We only depend on flex when we patch the input lexer.
+DEPEND="${RDEPEND}"
+
+DOCS="AUTHORS ChangeLog FAQ NEWS README THANKS"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.0.22-format_fo_passivetex_check.patch )
+
+src_prepare() {
+ default
+
+ # fix symbol clash on Solaris
+ if [[ ${CHOST} == *-solaris* ]] ; then
+ sed -i -e 's/\(attrib\|val\)/XMLTO\1/g' xmlif/xmlif.l || die
+ fi
+}
+
+src_configure() {
+ # We don't want the script to detect /bin/sh if it is bash.
+ export ac_cv_path_BASH=${BASH}
+ has_version sys-apps/util-linux || export GETOPT=getopt-long
+ econf
+}