summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorBen Kohler <bkohler@gentoo.org>2020-08-26 10:46:39 -0500
committerBen Kohler <bkohler@gentoo.org>2020-08-26 11:15:14 -0500
commitc3290dbbe5da9be91226019d895ca29ef8eebdcf (patch)
tree9aaefa798373cf3c464a7b32530dd5f5d2372b46 /app-text
parentgames-fps/chocolate-doom: New package (diff)
downloadgentoo-c3290dbbe5da9be91226019d895ca29ef8eebdcf.tar.gz
gentoo-c3290dbbe5da9be91226019d895ca29ef8eebdcf.tar.bz2
gentoo-c3290dbbe5da9be91226019d895ca29ef8eebdcf.zip
app-text/discount: bump to 2.2.7
Package-Manager: Portage-3.0.4, Repoman-3.0.1 Signed-off-by: Ben Kohler <bkohler@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/discount/Manifest1
-rw-r--r--app-text/discount/discount-2.2.7.ebuild69
2 files changed, 70 insertions, 0 deletions
diff --git a/app-text/discount/Manifest b/app-text/discount/Manifest
index 765535752cfd..237878fcfa8b 100644
--- a/app-text/discount/Manifest
+++ b/app-text/discount/Manifest
@@ -1,2 +1,3 @@
DIST discount-2.2.4.tar.bz2 99482 BLAKE2B b04c372cef27d0a4a09a588eb66376dc70494eefe5c8a9e7aedb8075f081a6f32eafbb9671c29deea7d89128f4f30c93d38c17268eccbb1c917db6c1b7d3e040 SHA512 0650e0ce3f6948e3a30fdaa1a810e895f64621c55df46c7a5ed8755e65c1b718b7a1d1a1bfe0a87a3a59fbb13fca8907718f1aa095125a4b6e152602b8e490cf
DIST discount-2.2.6.tar.bz2 102303 BLAKE2B 6ffcb64ff8889d79832b28db9a824e5a30bd194a6746dd08e4782cb4b7e60cf47c44f244884fc10372fc2b052fff7d70e6c263e6f4175829d1aedbc8c2ea15c6 SHA512 b67395afed0899563e28fdd2ddd5016d4f382b6b7e46612d12853d701ba191b90771d40e1223e24e3fbf497cad01fdd2e1c67a6b2bf4f6cf082f3fbe981bd002
+DIST discount-2.2.7.tar.bz2 102277 BLAKE2B 58ec3bce2b8fc41a090d9b81b4326cbf54e36bf774f4f9ef63c2a2b1d34ba464e9f0a021f19b4fef165da426742af3045a631af005371d1a8a4cd81dc0be3367 SHA512 1b61eb7c625bb50da0dbe97350a0ccbb15930ccaef449c4b4659950907bce3c0564dabf20578379a7fdd0e375f5d4d5b61acd34db474a85e942b60373688bd08
diff --git a/app-text/discount/discount-2.2.7.ebuild b/app-text/discount/discount-2.2.7.ebuild
new file mode 100644
index 000000000000..9cb5d5ea9f15
--- /dev/null
+++ b/app-text/discount/discount-2.2.7.ebuild
@@ -0,0 +1,69 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit toolchain-funcs
+
+DESCRIPTION="A Markdown-to HTML translator written in C"
+HOMEPAGE="http://www.pell.portland.or.us/~orc/Code/discount/"
+SRC_URI="http://www.pell.portland.or.us/~orc/Code/${PN}/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~ia64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="minimal test"
+RESTRICT="!test? ( test )"
+
+PATCHES=( "${FILESDIR}"/gethopt-undefined.patch )
+
+src_prepare() {
+ default
+
+ # for QA, we remove the Makefile’s usage of install -s.
+ # Drop ldconfig invocation.
+ # Force “librarian.sh” to respect LDFLAGS ($FLAGS should have CFLAGS
+ # at that point).
+ sed -i \
+ -e '/INSTALL_PROGRAM/s,\$_strip ,,' \
+ -e 's/\(LDCONFIG=\).*/\1:/' \
+ -e 's/\(.\)\$FLAGS/& \1$LDFLAGS/' \
+ configure.inc || die "sed configure.inc failed"
+}
+
+src_configure() {
+ local configure_call=(
+ ./configure.sh
+ --libdir="${EPREFIX}"usr/"$(get_libdir)"
+ --prefix="${EPREFIX}"usr
+ --mandir="${EPREFIX}"usr/share/man
+ --shared
+ --pkg-config
+ $(usex minimal '' --enable-all-features)
+ # Enable deterministic HTML generation behavior. Otherwise, will
+ # actually call rand() as part of its serialization code...
+ --debian-glitch
+ )
+ einfo "Running ${configure_call[@]}"
+ CC="$(tc-getCC)" AR="$(tc-getAR)" \
+ "${configure_call[@]}" || die
+}
+
+src_compile() {
+ emake libmarkdown
+ emake
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ $(usex minimal install install.everything) \
+ SAMPLE_PFX="${PN}-"
+}
+
+pkg_postinst() {
+ if ! use minimal; then
+ elog 'Sample binaries with overly-generic names have been'
+ elog "prefixed with \"${PN}-\"."
+ fi
+}