summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMart Raudsepp <leio@gentoo.org>2020-03-29 12:54:16 +0300
committerMart Raudsepp <leio@gentoo.org>2020-03-29 12:55:41 +0300
commitcb22f47abd9ff8969c984f8febb819d8dcc5fcd1 (patch)
tree11667d68ab4772fb964d599afbb70d1e67a687cb /app-text
parentdev-lang/vala: bump p.masked to 0.48.2 (diff)
downloadgentoo-cb22f47abd9ff8969c984f8febb819d8dcc5fcd1.tar.gz
gentoo-cb22f47abd9ff8969c984f8febb819d8dcc5fcd1.tar.bz2
gentoo-cb22f47abd9ff8969c984f8febb819d8dcc5fcd1.zip
app-text/enchant: bump to 2.2.8
Package-Manager: Portage-2.3.84, Repoman-2.3.20 Signed-off-by: Mart Raudsepp <leio@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/enchant/Manifest1
-rw-r--r--app-text/enchant/enchant-2.2.8.ebuild44
2 files changed, 45 insertions, 0 deletions
diff --git a/app-text/enchant/Manifest b/app-text/enchant/Manifest
index 2ca1681a21f3..035cc86a7fc5 100644
--- a/app-text/enchant/Manifest
+++ b/app-text/enchant/Manifest
@@ -1,2 +1,3 @@
DIST enchant-1.6.1.tar.gz 642124 BLAKE2B d41aa9b313e7fe8b0887728b55f3c5218e270c7359b4edcdc8d9180af68687230bcc9f7d1abb9f85ac673478530e5674366c9bc7d08b983e7226725b2cdd73d3 SHA512 26c62dfa89ee40150db502651a2f876fba00569b7015f205dae27a029557effacff335bbe36124dbe6686537da2305bcab02592179d03e95fdf9741d54b98036
DIST enchant-2.2.7.tar.gz 951995 BLAKE2B 32232a0a8e5003dcc056b6916f95274f357ac2ab69a08fde806da12487f63eba273a57049250fc75699fb545e98e25b95dcaf00c67af2ceabe779b8798f24a5a SHA512 696455cf782b3186d19988ed59ca3cc6030a431d44ef3828039590afb08fd282a79ce6246a342e6bf7a0bf3bf63d4822d841ba01394da9f9e4394a491b2373b6
+DIST enchant-2.2.8.tar.gz 976715 BLAKE2B 50a96c69b6f6575db0a8d6f30420db4b273901a9a0261ae606d81d96b044ece03078a2549f34972fef47a36f0b85c27af90c90c2f2efab2fb258e17621d927af SHA512 4bfa771af0deab3d0ca5523abab1fdb14cb596747dba7cf887e8cd812601015f52502cbd3df68247f102bba259cb281414e9ccde83b8bdd3c8cc83c2fcbc9090
diff --git a/app-text/enchant/enchant-2.2.8.ebuild b/app-text/enchant/enchant-2.2.8.ebuild
new file mode 100644
index 000000000000..d4c6ef72a6e5
--- /dev/null
+++ b/app-text/enchant/enchant-2.2.8.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="Spellchecker wrapping library"
+HOMEPAGE="https://abiword.github.io/enchant/"
+SRC_URI="https://github.com/AbiWord/enchant/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1+"
+SLOT="2"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x86-macos ~x86-solaris"
+
+IUSE="aspell +hunspell"
+REQUIRED_USE="|| ( hunspell aspell )"
+
+# FIXME: depends on unittest++ but through pkgconfig which is a Debian hack, bug #629742
+RDEPEND="
+ >=dev-libs/glib-2.6:2
+ aspell? ( app-text/aspell )
+ hunspell? ( >=app-text/hunspell-1.2.1:0= )"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+# test? ( dev-libs/unittest++ )
+RESTRICT="test"
+
+src_configure() {
+ # TODO: Add app-text/nuspell support
+ econf \
+ --datadir="${EPREFIX}"/usr/share/enchant-2 \
+ --disable-static \
+ $(use_with aspell) \
+ $(use_with hunspell) \
+ --without-hspell \
+ --without-nuspell \
+ --without-voikko \
+ --with-hunspell-dir="${EPREFIX}"/usr/share/hunspell/
+}
+
+src_install() {
+ default
+ find "${D}" -name '*.la' -delete || die
+}