summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDavid Heidelberg <david@ixit.cz>2020-04-11 13:29:38 +0200
committerJoonas Niilola <juippis@gentoo.org>2020-05-15 13:15:45 +0300
commitcc9da233f44c2bcce96b01e364123b8fbc26be8e (patch)
tree8b8a06e1d7b2eb2bc6dc5a3447b5791512257b92 /app-text
parentsys-devel/bmake: bump to 20200318 (diff)
downloadgentoo-cc9da233f44c2bcce96b01e364123b8fbc26be8e.tar.gz
gentoo-cc9da233f44c2bcce96b01e364123b8fbc26be8e.tar.bz2
gentoo-cc9da233f44c2bcce96b01e364123b8fbc26be8e.zip
app-text/recode: bump to 3.7.6
- bump to EAPI 7 - switch to BDEPEND - tests are working now Bug: https://bugs.gentoo.org/717054 Signed-off-by: David Heidelberg <david@ixit.cz> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/recode/Manifest1
-rw-r--r--app-text/recode/recode-3.7.6.ebuild36
2 files changed, 37 insertions, 0 deletions
diff --git a/app-text/recode/Manifest b/app-text/recode/Manifest
index f0916dc1093d..8ae0154eeca8 100644
--- a/app-text/recode/Manifest
+++ b/app-text/recode/Manifest
@@ -1,3 +1,4 @@
DIST recode-3.6.tar.gz 1751886 BLAKE2B 94436343969da0ee6d16ed69a211d4f36b7a9cb59ce931ef71cfc1e0f11e5709e67ee1e0bb24f5320e6c7d6d01920a6c4d9edce87ff2c6aaaa8c80e30f3b536d SHA512 68de277ac8cd5f6023bb077b959ab5778a78edac1299d507bab906824080b6f86e9bfcd89169aa474197c2faa9af2ceb1ed272c8dd4d50caef373afa05daed1b
+DIST recode-3.7.6.tar.gz 2210564 BLAKE2B 8c99b6d2eb93482785fe7e36063514e4c153516cc8059a9b98fc9f1b08704314b7933390a5fd7921525648ef58e9f995242182b8de23b7db33cbf94383e28f29 SHA512 ababefc445fcc47b6bf9ed640b767aed374bb8ce93cdccb641dd1ba5d298360583dd79070a0bb458f1190a8d6f1ddeb3b04eec34a61305b69def0963cec5843f
DIST recode-3.7_pre20140303.tar.gz 1580388 BLAKE2B 8fb280368e6998c8cb4554f856dd779e70fd53958bf6da5839735e14e741f45b110ac106494703d97ac3390f41736b2d94539dfde4554b3ca70911788ce8c005 SHA512 a1821909e7ba68a315bbd5e0dcaf0a574f09ac6ef1ccf8858aeda1a0affc09cb70353b4bda005a14cff37ef41646a6f5246c5b5a0f6e89db2065eac7ace9b030
DIST recode_3.6-20.debian.tar.gz 341117 BLAKE2B 748ee36b68f1d1501edde23e8afcbd58df70a86745e7c366a27a33496e539dcae11b746fb46767e95ae99b68a18684e3e85c1ea961692ac57ad1a01a895734a7 SHA512 bc586534e77b49da7d387187a8ddb042a12871f87f4f32c818ce7218b7254ac5ba6eccb14aaaf0312579f27958883f2da620016a7049c3af24c8bfba81acc3ef
diff --git a/app-text/recode/recode-3.7.6.ebuild b/app-text/recode/recode-3.7.6.ebuild
new file mode 100644
index 000000000000..cdbdbc5bc6d3
--- /dev/null
+++ b/app-text/recode/recode-3.7.6.ebuild
@@ -0,0 +1,36 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit flag-o-matic libtool toolchain-funcs
+
+DESCRIPTION="Convert files between various character sets"
+HOMEPAGE="https://github.com/rrthomas/recode"
+SRC_URI="https://github.com/rrthomas/recode/releases/download/v${PV}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~sparc-solaris ~x86-solaris"
+IUSE="nls static-libs"
+
+DEPEND="sys-devel/flex"
+BDEPEND="
+ nls? ( sys-devel/gettext )
+"
+
+src_configure() {
+ tc-export CC LD
+ # on solaris -lintl is needed to compile
+ [[ ${CHOST} == *-solaris* ]] && append-libs "-lintl"
+ # --without-included-gettext means we always use system headers
+ # and library
+ econf \
+ $(use_enable nls) \
+ $(use_enable static-libs static)
+}
+
+src_install() {
+ default
+ find "${ED}" -name '*.la' -exec rm -v {} + || die
+}