summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Deutschmann <whissi@gentoo.org>2021-10-15 15:55:31 +0200
committerThomas Deutschmann <whissi@gentoo.org>2021-10-15 16:32:58 +0200
commitdbf67fc2e4b4b36720e29d6dcec64f6b5a3af580 (patch)
treeb8b0ba139bd98db073d283311ed69e790ec868cc /app-text
parentsys-apps/fwupd: bump to v1.7.0 (diff)
downloadgentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.tar.gz
gentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.tar.bz2
gentoo-dbf67fc2e4b4b36720e29d6dcec64f6b5a3af580.zip
app-text/vgrep: bump to v2.5.2
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Thomas Deutschmann <whissi@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/vgrep/Manifest1
-rw-r--r--app-text/vgrep/vgrep-2.5.2.ebuild30
2 files changed, 31 insertions, 0 deletions
diff --git a/app-text/vgrep/Manifest b/app-text/vgrep/Manifest
index fb996f7ee814..356b2e984d0c 100644
--- a/app-text/vgrep/Manifest
+++ b/app-text/vgrep/Manifest
@@ -1 +1,2 @@
DIST vgrep-2.5.1.tar.gz 1355092 BLAKE2B 82b9da137400ede07b3fc2472168139385df8ee639aa0ba34832d20e437ac3da5a86f89fcc9139faa0ca3a037a358a50947b982473d114056483aaf9cfdde52e SHA512 97561ac933fa8a716c9205910d088bf0bb852f2d68ea2226e27e30b5885aabd37223ec4368d72cd0ae5c72735e273004bd054a2b633e61ecb7fd854254cfaecd
+DIST vgrep-2.5.2.tar.gz 1571753 BLAKE2B c3378fa11e9bb88fb8d63a380722603efa0725e2d43b69aafbb6ff8788abab441f1fbd3d0c946c922c8100863c185623b41aa76a04e81aab302b26d68f5956d7 SHA512 dc63647b995a21e75d9658efd7e9bcc4c706221ac249d0273cf6997eef832ba4a27f825126fb3fb4c65d724c75e27d04e9b5505b0b65c9b9b0022a49580011a6
diff --git a/app-text/vgrep/vgrep-2.5.2.ebuild b/app-text/vgrep/vgrep-2.5.2.ebuild
new file mode 100644
index 000000000000..8946ea7fa45b
--- /dev/null
+++ b/app-text/vgrep/vgrep-2.5.2.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+inherit go-module
+
+DESCRIPTION="A pager for grep, git-grep and similar grep implementations"
+HOMEPAGE="https://github.com/vrothberg/vgrep"
+SRC_URI="https://github.com/vrothberg/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="BSD GPL-3+ MIT MIT-with-advertising"
+SLOT="0"
+KEYWORDS="~amd64"
+
+# golangci-lint is required to run tests which is not yet packaged
+RESTRICT="strip test"
+
+BDEPEND="dev-go/go-md2man"
+
+DOCS=( README.md )
+
+src_compile() {
+ emake build
+}
+
+src_install() {
+ emake PREFIX="${D}/usr" install
+ einstalldocs
+}