summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2023-06-26 17:42:55 +0100
committerSam James <sam@gentoo.org>2023-06-26 17:47:20 +0100
commite1011cbbec6f65f2df32143c12e705c8cee25d7c (patch)
tree6f77cdd2f6d2dfa813c2f42b642f0a960196fc1e /app-text
parentsys-auth/passwdqc: add 2.0.3 (diff)
downloadgentoo-e1011cbbec6f65f2df32143c12e705c8cee25d7c.tar.gz
gentoo-e1011cbbec6f65f2df32143c12e705c8cee25d7c.tar.bz2
gentoo-e1011cbbec6f65f2df32143c12e705c8cee25d7c.zip
app-text/lesspipe: add 2.08
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/lesspipe/Manifest1
-rw-r--r--app-text/lesspipe/lesspipe-2.08.ebuild52
2 files changed, 53 insertions, 0 deletions
diff --git a/app-text/lesspipe/Manifest b/app-text/lesspipe/Manifest
index 8c235e3842dd..f8a4645c5cad 100644
--- a/app-text/lesspipe/Manifest
+++ b/app-text/lesspipe/Manifest
@@ -1,2 +1,3 @@
DIST lesspipe-2.06.tar.gz 168100 BLAKE2B a7447efa85cd422343f9dbb06001e85fa7b33c92db752f8248e4b4a0d9ecce4ef0241240d6993c5a71157c44da2f4ffc3efd41ac5e0a31e89ed5b80ac99f71fe SHA512 b2411c5e6b287fb67e1ea9b6d10377fe19b58e8c0f54587f825d1ee4c1a85f9a8ed3244a7cf339bcba960094e95821d9a56929951d862eb697f1d12fe55ef20d
DIST lesspipe-2.07.tar.gz 168973 BLAKE2B b9be5968d808dc57caa00551cdf663be75dff1c9662b585ddd2e1891f6f66fce0b71a468d9b9172af2833bd6ee255ad9b5fb917dac527eeb8b57427c568cd620 SHA512 6fa5debfa5b72fa5826294eca158a935a0b49dc431bd27eb7dc598315592d575ad302bb94fcdb86409dce1cb7055242ff10eb09cbf3708e472b8dbe8286d5511
+DIST lesspipe-2.08.tar.gz 169527 BLAKE2B c1b1e4b9d3b24f7a9547f25a276bdee7aebf35777401441bb9bbefef3f3ff319ca8ef330c76e969811cbb2047a539aa4d2dbea5059c5ed06a69bea43d54f94a9 SHA512 309f69240308eab082ed9bff1bda1785eb8394022e576ff49656816cf793e0f3bb26bb0f41eff4c1437ed7719cbd810a83d75d8a1a08a11a8cf378c1741397bd
diff --git a/app-text/lesspipe/lesspipe-2.08.ebuild b/app-text/lesspipe/lesspipe-2.08.ebuild
new file mode 100644
index 000000000000..1380abbeb29c
--- /dev/null
+++ b/app-text/lesspipe/lesspipe-2.08.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit edo bash-completion-r1
+
+DESCRIPTION="A preprocessor for less"
+HOMEPAGE="https://github.com/wofr06/lesspipe"
+SRC_URI="https://github.com/wofr06/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos ~x64-macos ~x64-solaris"
+IUSE="test"
+
+# Please check again on bumps!
+# bug #734896
+RESTRICT="!test? ( test ) test"
+
+RDEPEND="dev-lang/perl"
+BDEPEND="
+ ${RDEPEND}
+ virtual/pkgconfig
+ test? ( app-editors/vim )
+"
+
+src_configure() {
+ # Not an autoconf script.
+ edo ./configure --prefix="${EPREFIX}"/usr
+}
+
+src_compile() {
+ # Nothing to build (avoids the "all" target)
+ :
+}
+
+src_install() {
+ emake PREFIX="${EPREFIX}/usr" DESTDIR="${D}" install
+ einstalldocs
+
+ rm "${ED}"/usr/share/bash-completion/less_completion || die
+ newbashcomp less_completion less
+}
+
+pkg_preinst() {
+ if [[ -z ${REPLACING_VERSIONS} ]] ; then
+ elog "This package installs 'lesspipe.sh' which is distinct from 'lesspipe'."
+ elog "The latter is the Gentoo-specific version. Make sure to update your"
+ elog "LESSOPEN environment variable if you wish to use this copy."
+ fi
+}