summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 12:08:49 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 12:13:10 +0200
commite10be8fca2dbab93315cd90eb28245194ebf7c44 (patch)
tree14f5b85a810d1c5656fed8d8f485087c3d40d6a6 /app-text
parentapp-text/bibus: Drop old (diff)
downloadgentoo-e10be8fca2dbab93315cd90eb28245194ebf7c44.tar.gz
gentoo-e10be8fca2dbab93315cd90eb28245194ebf7c44.tar.bz2
gentoo-e10be8fca2dbab93315cd90eb28245194ebf7c44.zip
app-text/bibus: Fix for gentoo specific paths and fix for lo-4
Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=485396 Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=562214 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/bibus/Manifest1
-rw-r--r--app-text/bibus/bibus-1.5.2-r2.ebuild (renamed from app-text/bibus/bibus-1.5.2-r1.ebuild)10
-rw-r--r--app-text/bibus/files/bibus-1.5.2-bibus.cfg.patch31
3 files changed, 40 insertions, 2 deletions
diff --git a/app-text/bibus/Manifest b/app-text/bibus/Manifest
index 04ed1826bdad..ad942e9a7614 100644
--- a/app-text/bibus/Manifest
+++ b/app-text/bibus/Manifest
@@ -1 +1,2 @@
+DIST bibus-1.5.2-lo-4.patch.xz 13196 SHA256 b7147230929c304ab357c6a725c5cabbd577607e6200df968cdf2c057603c8a1 SHA512 68b90574e9dd0bb3e2cc89c539ff35febdf4ac37dfb65c06709d21b62fdda0108c93f05d37ab96bf52c4f99bbe20caa361d562c297b05dc7ea37404eea659fd1 WHIRLPOOL d807d81277fac722c50d98575939142a6f1f5a1e9eb88dec0acf0053349f54ecce7d7dcf070742b143bbf166704994b401eeb1e1ecd3e32c351d9bc41c09d1d8
DIST bibus_1.5.2.orig.tar.gz 5411889 SHA256 c6c66d6bdce403b7791bf58cc16eeaae9f0e9d1c3f0ba8411f9f3e694d740f02 SHA512 33d091dacc707859a11010fcba57691a3e2726ae7579d601720b4398f7be29b580be978da8cd058fab491ec5b52dd3ce33c964a8d5077f8e80d8f0f387ffa2c4 WHIRLPOOL 964f13902a8a20d9e838784cf1f0a032bb2327cd28f3b2470c35a7394ae7f7536a7884d798a8308049a02f6976183ffb1c56cc4d8b20dce13f98033668a90d38
diff --git a/app-text/bibus/bibus-1.5.2-r1.ebuild b/app-text/bibus/bibus-1.5.2-r2.ebuild
index 17f6d3b51749..f4de2beb028d 100644
--- a/app-text/bibus/bibus-1.5.2-r1.ebuild
+++ b/app-text/bibus/bibus-1.5.2-r2.ebuild
@@ -11,7 +11,10 @@ inherit eutils fdo-mime multilib python-r1 versionator
DESCRIPTION="Bibliographic and reference management software, integrates with L/OO.o and MS Word"
HOMEPAGE="http://bibus-biblio.sourceforge.net/"
-SRC_URI="mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz"
+SRC_URI="
+ mirror://sourceforge/${PN}-biblio/${PN}_${PV}.orig.tar.gz
+ https://dev.gentoo.org/~jlec/distfiles/${P}-lo-4.patch.xz
+ "
LICENSE="GPL-2"
SLOT="0"
@@ -45,7 +48,10 @@ pkg_setup() {
}
src_prepare() {
- epatch "${FILESDIR}"/${P}-install.patch
+ epatch \
+ "${FILESDIR}"/${P}-install.patch \
+ "${FILESDIR}"/${P}-bibus.cfg.patch \
+ "${WORKDIR}"/${P}-lo-4.patch
}
src_compile() { :; }
diff --git a/app-text/bibus/files/bibus-1.5.2-bibus.cfg.patch b/app-text/bibus/files/bibus-1.5.2-bibus.cfg.patch
new file mode 100644
index 000000000000..bfba0c0ac43b
--- /dev/null
+++ b/app-text/bibus/files/bibus-1.5.2-bibus.cfg.patch
@@ -0,0 +1,31 @@
+ bibusStart.py | 8 +++++---
+ 1 file changed, 5 insertions(+), 3 deletions(-)
+
+diff --git a/bibusStart.py b/bibusStart.py
+index edfc19f..99c5381 100644
+--- a/bibusStart.py
++++ b/bibusStart.py
+@@ -17,12 +17,14 @@
+ # along with Bibus; if not, write to the Free Software
+ # Foundation, Inc., 51 Franklin St, Fifth Floor, Boston, MA 02110-1301 USA.
+ #
+-import ConfigParser,os,sys,urllib,urlparse
++import ConfigParser,os,sys,urllib,urlparse,site
+ cp=ConfigParser.ConfigParser()
+ fileName = sys.argv[0]
+ while os.path.islink(fileName): fileName = os.readlink(fileName)
+ sourcedir = os.path.abspath( os.path.dirname(fileName) )
+-cp.read( os.path.join(sourcedir,'bibus.cfg') )
++bibus_sitedir = os.path.join(site.getsitepackages()[0], 'bibus')
++bibus_cfg = os.path.join(bibus_sitedir, 'bibus.cfg')
++cp.read(bibus_cfg)
+ # We read first, then if it is not null we convert to absolute path
+ # otherwise, empty path will be converted to the current directory path
+ python = cp.get('PATH','python')
+@@ -69,5 +71,5 @@ else:
+ except KeyError:
+ os.environ[LIBPATH] = oopath
+ # starting Bibus
+-os.execl( python , os.path.basename(python) , QUOTE+ os.path.join(sourcedir,'bibus.py') +QUOTE )
++os.execl( python , os.path.basename(python) , QUOTE+ os.path.join(bibus_sitedir,'bibus.py') +QUOTE )
+