summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSam James <sam@gentoo.org>2024-03-15 05:30:23 +0000
committerSam James <sam@gentoo.org>2024-03-15 05:30:23 +0000
commite791f939d47ef68c6cc716408abc090bcce1fdb7 (patch)
treec511bcdc14595c5a7e4a87d8b64eefa26a40acd8 /app-text
parentmedia-sound/milkytracker: mark as LTO-unsafe (diff)
downloadgentoo-e791f939d47ef68c6cc716408abc090bcce1fdb7.tar.gz
gentoo-e791f939d47ef68c6cc716408abc090bcce1fdb7.tar.bz2
gentoo-e791f939d47ef68c6cc716408abc090bcce1fdb7.zip
app-text/a2ps: add 4.15.6
Signed-off-by: Sam James <sam@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/a2ps/Manifest1
-rw-r--r--app-text/a2ps/a2ps-4.15.6.ebuild92
2 files changed, 93 insertions, 0 deletions
diff --git a/app-text/a2ps/Manifest b/app-text/a2ps/Manifest
index ed6f6d8e0450..1038254cb39a 100644
--- a/app-text/a2ps/Manifest
+++ b/app-text/a2ps/Manifest
@@ -1 +1,2 @@
DIST a2ps-4.15.5.tar.gz 3571724 BLAKE2B 7c352b72c537f8519cafb7993595d902e1dfeae49207936c365b0ea3813ffff973c5f5e2bb63a4cffa3c665990d95c8a8e339c87d9eac25fa24e364b8b705bae SHA512 e9953659139a46aed46e190d5485382a9e396ae8bbbe59edb78ab3110e7839a764e3cb6ff94f5f36e6e91fcaf85f6352376e0b4a0e0141f24e098fa334b5015e
+DIST a2ps-4.15.6.tar.gz 3605392 BLAKE2B 64f79e26ef116836508c94f0e846f2d242fbb551e9324f339dcc2f8c8cedfad0a708bf10a74cb8e45dad14e1390f4adfb8763618b24794b9cdf77202ebfee33f SHA512 23d054a2e58c28460c5e23a1cf3f0f9c27faffc9a99781c42c11cc0693eea5bb8cfe090a97b9bae3d80cfae6b4d5b9a30dfd997a2d70be2d25988c714ad14b44
diff --git a/app-text/a2ps/a2ps-4.15.6.ebuild b/app-text/a2ps/a2ps-4.15.6.ebuild
new file mode 100644
index 000000000000..f9ae315b9f23
--- /dev/null
+++ b/app-text/a2ps/a2ps-4.15.6.ebuild
@@ -0,0 +1,92 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools elisp-common
+
+DESCRIPTION="Any to PostScript filter"
+HOMEPAGE="https://www.gnu.org/software/a2ps/"
+SRC_URI="mirror://gnu/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="cjk emacs latex nls static-libs vanilla"
+
+# a2ps-lpr-wrapper needs bash
+RDEPEND="
+ app-text/ghostscript-gpl
+ app-text/libpaper:=
+ >=app-text/psutils-1.17
+ app-text/wdiff
+ app-shells/bash:*
+ dev-libs/boehm-gc
+ >=sys-apps/coreutils-6.10-r1
+ emacs? ( >=app-editors/emacs-23.1:* )
+ latex? ( virtual/latex-base )
+ nls? ( virtual/libintl )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ app-alternatives/yacc
+ >=dev-util/gperf-2.7.2
+ nls? ( sys-devel/gettext )
+"
+
+SITEFILE="50${PN}-gentoo.el"
+
+QA_CONFIG_IMPL_DECL_SKIP=(
+ # gnulib FPs
+ MIN alignof static_assert
+)
+
+src_prepare() {
+ default
+
+ use vanilla || eapply "${FILESDIR}"/${PN}-4.15-stdout.patch
+
+ eautoreconf
+}
+
+src_configure() {
+ export LANG=C LC_ALL=C
+
+ econf \
+ --cache-file="${S}"/config.cache \
+ --enable-shared \
+ $(use_enable static-libs static) \
+ --sysconfdir="${EPREFIX}"/etc/a2ps \
+ $(use_enable nls) \
+ COM_netscape=no \
+ COM_acroread=no \
+ $(usev !latex COM_latex=no) \
+ $(usev !emacs EMACS=no)
+}
+
+src_install() {
+ emake \
+ DESTDIR="${D}" \
+ lispdir="${EPREFIX}${SITELISP}"/${PN} \
+ install
+
+ einstalldocs
+
+ newdoc "${ED}"/usr/share/a2ps/README README.a2ps
+ newdoc "${ED}"/usr/share/a2ps/ppd/README README.a2ps.ppd
+ newdoc "${ED}"/usr/share/ogonkify/README README.ogonkify
+
+ rm -f "${ED}"/usr/share/{a2ps,a2ps/ppd,ogonkify}/README || die
+
+ find "${ED}" -name '*.la' -delete || die
+
+ use emacs && elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}