summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2015-10-22 10:52:11 +0200
committerJustin Lecher <jlec@gentoo.org>2015-10-22 10:52:11 +0200
commitf53b21d5514b81eed9610c1e7ec77f97043d020d (patch)
tree5af0ec4e844db53533131ed1a7ff52c9e5ffcdc8 /app-text
parentdev-python/astropy: Properly block dev-python/pyfits (diff)
downloadgentoo-f53b21d5514b81eed9610c1e7ec77f97043d020d.tar.gz
gentoo-f53b21d5514b81eed9610c1e7ec77f97043d020d.tar.bz2
gentoo-f53b21d5514b81eed9610c1e7ec77f97043d020d.zip
app-text/pdfgrep: Version Bump
thanks Florian Schmaus for the initial ebuild Gentoo-Bug: https://bugs.gentoo.org/show_bug.cgi?id=563764 Package-Manager: portage-2.2.23 Signed-off-by: Justin Lecher <jlec@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/pdfgrep/Manifest1
-rw-r--r--app-text/pdfgrep/pdfgrep-1.4.1.ebuild31
2 files changed, 32 insertions, 0 deletions
diff --git a/app-text/pdfgrep/Manifest b/app-text/pdfgrep/Manifest
index 3bc822464b94..7e72ff8d46ef 100644
--- a/app-text/pdfgrep/Manifest
+++ b/app-text/pdfgrep/Manifest
@@ -1,2 +1,3 @@
DIST pdfgrep-1.3.1.tar.gz 111653 SHA256 6e8bcaf8b219e1ad733c97257a97286a94124694958c27506b2ea7fc8e532437 SHA512 7a13016a8cf4f8a7387940d7e3862a1fb83f3aa6240084f835e92e958836dff0788db2ae39f35db25d679a2857ddf0b9bcbd7b1aacb10c2a16c3165d56f4efcf WHIRLPOOL 94b69bd0e16d4f0b1b389b09c2330516f25cc772be58e7ad49a2cf1ac0633539bb16a5df595052f468ab89d38ebeeb26b7f2be866555756f423febbf0a600b4b
DIST pdfgrep-1.3.2.tar.gz 114754 SHA256 386b167434443dd299d389a0ef292d708123255cbab0e179e11b65ba51d9b386 SHA512 dd5d26999405e1e84f5639ea48e15d2aab951a766f828e8e7b45409a7e027a5312757ac64952da56b8a37cf0cd0bc6f43cd16d78600dcc6c8fcb4deabecf0a5b WHIRLPOOL d2ca79e647a21767e0296d72dcdb511157352adf1f1d60beec9d15eb46554f3ec6d9c11f1dfda8988d4f6dcf4a814c52a8ffc28f72c2f227e01430354a8b99f9
+DIST pdfgrep-1.4.1.tar.gz 151926 SHA256 db04a210e6bb7b77cd6c54b17f0f6fed0d123a85f97a541b270736a5d3840f2c SHA512 27ce23c25a5f284b3eba92a0f8dbf02600248548967c1e71dfb41e43528824d9add587ea0ac23899ff07d2ffc6c74c2e6e4c2e7240e69494b8d31b7a4afc3735 WHIRLPOOL f08308a13b0b577215521b116db7b4c787b34993665031a690308e45333f35e86419928310b303060cda40aaf4ed5d474400bcee0e29106c9f8c8935d779687e
diff --git a/app-text/pdfgrep/pdfgrep-1.4.1.ebuild b/app-text/pdfgrep/pdfgrep-1.4.1.ebuild
new file mode 100644
index 000000000000..e4221d58fd3d
--- /dev/null
+++ b/app-text/pdfgrep/pdfgrep-1.4.1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+DESCRIPTION="A tool similar to grep which searches text in PDFs"
+HOMEPAGE="http://pdfgrep.org/"
+SRC_URI="https://pdfgrep.org/download/${P}.tar.gz"
+
+SLOT="0"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~x86"
+IUSE="+pcre test unac"
+
+RDEPEND="
+ app-text/poppler:=[cxx]
+ pcre? ( dev-libs/libpcre[cxx] )
+ unac? ( app-text/unac )"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig
+ test? (
+ dev-texlive/texlive-latex
+ dev-util/dejagnu
+ )"
+
+src_configure() {
+ econf \
+ $(use_with pcre) \
+ $(use_with unac)
+}