summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAndreas Sturmlechner <asturm@gentoo.org>2022-01-04 12:54:25 +0100
committerAndreas Sturmlechner <asturm@gentoo.org>2022-01-04 12:58:15 +0100
commitf7d3aeb9f6a10d62e906feab5d4a5c593f06ff89 (patch)
tree4df474ff49b30ce11b66d787be2c95ad504a3224 /app-text
parentdev-qt/qtsvg: 5.15.2-r12 version bump at KDE 0cb681ea (diff)
downloadgentoo-f7d3aeb9f6a10d62e906feab5d4a5c593f06ff89.tar.gz
gentoo-f7d3aeb9f6a10d62e906feab5d4a5c593f06ff89.tar.bz2
gentoo-f7d3aeb9f6a10d62e906feab5d4a5c593f06ff89.zip
app-text/kjots: Fix build with >=kde-apps/akonadi-21.12.0
Closes: https://bugs.gentoo.org/830580 Package-Manager: Portage-3.0.30, Repoman-3.0.3 Signed-off-by: Andreas Sturmlechner <asturm@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/kjots/files/kjots-5.1.0-akonadi-21.12.0.patch272
-rw-r--r--app-text/kjots/files/kjots-5.1.0-implicit-dep.patch26
-rw-r--r--app-text/kjots/files/kjots-5.1.0-missing-lib.patch25
-rw-r--r--app-text/kjots/kjots-5.1.0-r1.ebuild53
4 files changed, 376 insertions, 0 deletions
diff --git a/app-text/kjots/files/kjots-5.1.0-akonadi-21.12.0.patch b/app-text/kjots/files/kjots-5.1.0-akonadi-21.12.0.patch
new file mode 100644
index 000000000000..3f0c4e52779b
--- /dev/null
+++ b/app-text/kjots/files/kjots-5.1.0-akonadi-21.12.0.patch
@@ -0,0 +1,272 @@
+From 581548a1de9449efc0c77e9ac85c23066bac983e Mon Sep 17 00:00:00 2001
+From: "Friedrich W. H. Kossebau" <kossebau@kde.org>
+Date: Wed, 8 Sep 2021 00:58:25 +0200
+Subject: [PATCH] Adapt to new Akonadi libraries includes using the C++
+ namespace as prefix
+
+GIT_SILENT
+---
+ src/kjotsedit.cpp | 5 +++++
+ src/kjotsmodel.cpp | 6 ++++++
+ src/kjotsmodel.h | 6 ++++++
+ src/kjotswidget.cpp | 20 +++++++++++++++++++-
+ src/kjotswidget.h | 5 +++++
+ src/noteshared/notecreatorandselector.cpp | 7 +++++++
+ src/noteshared/notecreatorandselector.h | 6 ++++++
+ src/noteshared/notelockattribute.h | 6 ++++++
+ src/noteshared/notepinattribute.h | 6 ++++++
+ src/noteshared/standardnoteactionmanager.cpp | 8 ++++++++
+ src/noteshared/standardnoteactionmanager.h | 9 +++++++--
+ src/notesortproxymodel.cpp | 5 +++++
+ 12 files changed, 86 insertions(+), 3 deletions(-)
+
+diff --git a/src/kjotsedit.cpp b/src/kjotsedit.cpp
+index f1d61bd..c20bc42 100644
+--- a/src/kjotsedit.cpp
++++ b/src/kjotsedit.cpp
+@@ -33,7 +33,12 @@
+ #include <KPIMTextEdit/RichTextComposerActions>
+ #include <KPIMTextEdit/RichTextComposerImages>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/Item>
++#else
+ #include <AkonadiCore/Item>
++#endif
+
+ #include "kjotslinkdialog.h"
+ #include "kjotsmodel.h"
+diff --git a/src/kjotsmodel.cpp b/src/kjotsmodel.cpp
+index e35c94f..99ee14f 100644
+--- a/src/kjotsmodel.cpp
++++ b/src/kjotsmodel.cpp
+@@ -13,8 +13,14 @@
+ #include <QTextDocument>
+ #include <QIcon>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/ChangeRecorder>
++#include <Akonadi/EntityDisplayAttribute>
++#else
+ #include <AkonadiCore/ChangeRecorder>
+ #include <AkonadiCore/EntityDisplayAttribute>
++#endif
+ #include <Akonadi/Notes/NoteUtils>
+
+ #include <KMime/Message>
+diff --git a/src/kjotsmodel.h b/src/kjotsmodel.h
+index 71e0ca6..ec564a7 100644
+--- a/src/kjotsmodel.h
++++ b/src/kjotsmodel.h
+@@ -10,7 +10,13 @@
+ #ifndef KJOTSMODEL_H
+ #define KJOTSMODEL_H
+
++#include <akonadi_version.h>
++#include <QtGlobal> // for QT_VERSION_CHECK
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/EntityTreeModel>
++#else
+ #include <AkonadiCore/EntityTreeModel>
++#endif
+
+ class QTextDocument;
+
+diff --git a/src/kjotswidget.cpp b/src/kjotswidget.cpp
+index 3a3abd0..834fc33 100644
+--- a/src/kjotswidget.cpp
++++ b/src/kjotswidget.cpp
+@@ -35,6 +35,24 @@
+
+ // Akonadi
+ #include <Akonadi/Notes/NoteUtils>
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/AttributeFactory>
++#include <Akonadi/CollectionCreateJob>
++#include <Akonadi/CollectionDeleteJob>
++#include <Akonadi/ChangeRecorder>
++#include <Akonadi/EntityDisplayAttribute>
++#include <Akonadi/EntityMimeTypeFilterModel>
++#include <Akonadi/Item>
++#include <Akonadi/ItemCreateJob>
++#include <Akonadi/ItemModifyJob>
++#include <Akonadi/ItemDeleteJob>
++#include <Akonadi/ItemFetchScope>
++#include <Akonadi/EntityOrderProxyModel>
++#include <Akonadi/EntityTreeView>
++#include <Akonadi/ETMViewStateSaver>
++#include <Akonadi/ControlGui>
++#else
+ #include <AkonadiCore/AttributeFactory>
+ #include <AkonadiCore/CollectionCreateJob>
+ #include <AkonadiCore/CollectionDeleteJob>
+@@ -50,7 +68,7 @@
+ #include <AkonadiWidgets/EntityTreeView>
+ #include <AkonadiWidgets/ETMViewStateSaver>
+ #include <AkonadiWidgets/ControlGui>
+-
++#endif
+ // Grantlee
+ #include <grantlee/template.h>
+ #include <grantlee/engine.h>
+diff --git a/src/kjotswidget.h b/src/kjotswidget.h
+index 7fe91ed..00a41b5 100644
+--- a/src/kjotswidget.h
++++ b/src/kjotswidget.h
+@@ -18,7 +18,12 @@
+ #include <QAbstractItemDelegate>
+ #include <QPrinter>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/Collection>
++#else
+ #include <AkonadiCore/Collection>
++#endif
+
+ #include <grantlee/templateloader.h>
+
+diff --git a/src/noteshared/notecreatorandselector.cpp b/src/noteshared/notecreatorandselector.cpp
+index 2172cbf..6d58c83 100644
+--- a/src/noteshared/notecreatorandselector.cpp
++++ b/src/noteshared/notecreatorandselector.cpp
+@@ -14,9 +14,16 @@
+
+ #include <KMime/Message>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/EntityDisplayAttribute>
++#include <Akonadi/EntityTreeModel>
++#include <Akonadi/ItemCreateJob>
++#else
+ #include <AkonadiCore/EntityDisplayAttribute>
+ #include <AkonadiCore/EntityTreeModel>
+ #include <AkonadiCore/ItemCreateJob>
++#endif
+ #include <Akonadi/Notes/NoteUtils>
+
+ #include "noteshared_debug.h"
+diff --git a/src/noteshared/notecreatorandselector.h b/src/noteshared/notecreatorandselector.h
+index 90055cf..986d042 100644
+--- a/src/noteshared/notecreatorandselector.h
++++ b/src/noteshared/notecreatorandselector.h
+@@ -14,8 +14,14 @@
+ #include <QItemSelectionModel>
+ #include <QTimer>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/Collection>
++#include <Akonadi/Item>
++#else
+ #include <AkonadiCore/Collection>
+ #include <AkonadiCore/Item>
++#endif
+
+ class KJob;
+
+diff --git a/src/noteshared/notelockattribute.h b/src/noteshared/notelockattribute.h
+index 9bdd8a2..b0ee819 100644
+--- a/src/noteshared/notelockattribute.h
++++ b/src/noteshared/notelockattribute.h
+@@ -11,7 +11,13 @@
+ #ifndef KJOTS_LOCK_ATTRIBUTE_H
+ #define KJOTS_LOCK_ATTRIBUTE_H
+
++#include <akonadi_version.h>
++#include <QtGlobal> // for QT_VERSION_CHECK
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/Attribute>
++#else
+ #include <AkonadiCore/Attribute>
++#endif
+
+ namespace NoteShared
+ {
+diff --git a/src/noteshared/notepinattribute.h b/src/noteshared/notepinattribute.h
+index 3026dea..5f3903c 100644
+--- a/src/noteshared/notepinattribute.h
++++ b/src/noteshared/notepinattribute.h
+@@ -9,7 +9,13 @@
+ #ifndef NOTE_PIN_ATTRIBUTE_H
+ #define NOTE_PIN_ATTRIBUTE_H
+
++#include <akonadi_version.h>
++#include <QtGlobal> // for QT_VERSION_CHECK
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/Attribute>
++#else
+ #include <AkonadiCore/Attribute>
++#endif
+
+ namespace NoteShared
+ {
+diff --git a/src/noteshared/standardnoteactionmanager.cpp b/src/noteshared/standardnoteactionmanager.cpp
+index a3f4b8b..2a2f4ce 100644
+--- a/src/noteshared/standardnoteactionmanager.cpp
++++ b/src/noteshared/standardnoteactionmanager.cpp
+@@ -13,10 +13,18 @@
+ #include <QColorDialog>
+ #include <QItemSelectionModel>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/EntityDisplayAttribute>
++#include <Akonadi/EntityTreeModel>
++#include <Akonadi/CollectionModifyJob>
++#include <Akonadi/ItemModifyJob>
++#else
+ #include <AkonadiCore/EntityDisplayAttribute>
+ #include <AkonadiCore/EntityTreeModel>
+ #include <AkonadiCore/CollectionModifyJob>
+ #include <AkonadiCore/ItemModifyJob>
++#endif
+ #include <Akonadi/Notes/NoteUtils>
+
+ #include <KXmlGui/KActionCollection>
+diff --git a/src/noteshared/standardnoteactionmanager.h b/src/noteshared/standardnoteactionmanager.h
+index fe80dae..6605820 100644
+--- a/src/noteshared/standardnoteactionmanager.h
++++ b/src/noteshared/standardnoteactionmanager.h
+@@ -10,10 +10,15 @@
+ #ifndef AKONADI_STANDARDNOTESACTIONMANAGER_H
+ #define AKONADI_STANDARDNOTESACTIONMANAGER_H
+
+-#include <AkonadiWidgets/StandardActionManager>
+-
+ #include <QObject>
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/StandardActionManager>
++#else
++#include <AkonadiWidgets/StandardActionManager>
++#endif
++
+ class QAction;
+ class KActionCollection;
+ class QItemSelectionModel;
+diff --git a/src/notesortproxymodel.cpp b/src/notesortproxymodel.cpp
+index 89def1c..dbe582f 100644
+--- a/src/notesortproxymodel.cpp
++++ b/src/notesortproxymodel.cpp
+@@ -8,7 +8,12 @@
+
+ #include "notesortproxymodel.h"
+
++#include <akonadi_version.h>
++#if AKONADI_VERSION >= QT_VERSION_CHECK(5, 18, 41)
++#include <Akonadi/EntityTreeModel>
++#else
+ #include <AkonadiCore/EntityTreeModel>
++#endif
+
+ #include "noteshared/notepinattribute.h"
+
+--
+GitLab
+
diff --git a/app-text/kjots/files/kjots-5.1.0-implicit-dep.patch b/app-text/kjots/files/kjots-5.1.0-implicit-dep.patch
new file mode 100644
index 000000000000..b81bafc1889f
--- /dev/null
+++ b/app-text/kjots/files/kjots-5.1.0-implicit-dep.patch
@@ -0,0 +1,26 @@
+From 8803636bf4e0238d0f23bedebdcb4d1e6283ffb7 Mon Sep 17 00:00:00 2001
+From: Nicolas Fella <nicolas.fella@gmx.de>
+Date: Mon, 26 Apr 2021 17:09:51 +0200
+Subject: [PATCH] Make dependency on KI18n explicit
+
+It already pulled in by KParts, but we better not rely on that
+---
+ src/kontact_plugin/CMakeLists.txt | 2 +-
+ 1 file changed, 1 insertion(+), 1 deletion(-)
+
+diff --git a/src/kontact_plugin/CMakeLists.txt b/src/kontact_plugin/CMakeLists.txt
+index dec4b8b..f1d56ec 100644
+--- a/src/kontact_plugin/CMakeLists.txt
++++ b/src/kontact_plugin/CMakeLists.txt
+@@ -13,7 +13,7 @@ set(kontact_kjots_PART_SRCS
+ )
+
+ add_library(kontact_kjotsplugin MODULE ${kontact_kjots_PART_SRCS})
+-target_link_libraries(kontact_kjotsplugin KF5::KontactInterface)
++target_link_libraries(kontact_kjotsplugin KF5::I18n KF5::KontactInterface)
+ kcoreaddons_desktop_to_json(kontact_kjotsplugin kjotsplugin.desktop)
+
+ install(TARGETS kontact_kjotsplugin DESTINATION ${KDE_INSTALL_PLUGINDIR}/kontact5)
+--
+GitLab
+
diff --git a/app-text/kjots/files/kjots-5.1.0-missing-lib.patch b/app-text/kjots/files/kjots-5.1.0-missing-lib.patch
new file mode 100644
index 000000000000..28418717d3be
--- /dev/null
+++ b/app-text/kjots/files/kjots-5.1.0-missing-lib.patch
@@ -0,0 +1,25 @@
+From 3d3cee8caeec813802a1af54c14805203fb1ddf6 Mon Sep 17 00:00:00 2001
+From: "Friedrich W. H. Kossebau" <kossebau@kde.org>
+Date: Tue, 7 Sep 2021 23:21:34 +0200
+Subject: [PATCH] noteshared: add missing library to link list
+
+GIT_SILENT
+---
+ src/noteshared/CMakeLists.txt | 1 +
+ 1 file changed, 1 insertion(+)
+
+diff --git a/src/noteshared/CMakeLists.txt b/src/noteshared/CMakeLists.txt
+index 5de60ab..6aa0b0a 100644
+--- a/src/noteshared/CMakeLists.txt
++++ b/src/noteshared/CMakeLists.txt
+@@ -16,6 +16,7 @@ target_link_libraries(noteshared
+ Qt5::Core
+ Qt5::Widgets
+ KF5::I18n
++ KF5::AkonadiWidgets
+ KF5::AkonadiCore
+ KF5::AkonadiNotes
+ KF5::XmlGui
+--
+GitLab
+
diff --git a/app-text/kjots/kjots-5.1.0-r1.ebuild b/app-text/kjots/kjots-5.1.0-r1.ebuild
new file mode 100644
index 000000000000..dd1910ad60f6
--- /dev/null
+++ b/app-text/kjots/kjots-5.1.0-r1.ebuild
@@ -0,0 +1,53 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+KDE_ORG_CATEGORY="pim"
+KFMIN=5.82.0
+QTMIN=5.15.2
+inherit ecm kde.org
+
+DESCRIPTION="Note taking utility by KDE"
+HOMEPAGE="https://userbase.kde.org/KJots https://community.kde.org/PIM/KJots"
+
+if [[ ${KDE_BUILD_TYPE} != live ]]; then
+ SRC_URI="mirror://kde/stable/${PN}/${PV}/src/${P}.tar.xz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="5"
+IUSE=""
+
+DEPEND="
+ dev-libs/grantlee:5
+ >=dev-qt/qtdbus-${QTMIN}:5
+ >=dev-qt/qtgui-${QTMIN}:5
+ >=dev-qt/qtprintsupport-${QTMIN}:5
+ >=dev-qt/qtwidgets-${QTMIN}:5
+ >=kde-apps/akonadi-20.12.2:5
+ >=kde-apps/akonadi-notes-20.12.2:5
+ >=kde-apps/kmime-20.12.2:5
+ >=kde-apps/kontactinterface-20.12.2:5
+ >=kde-apps/kpimtextedit-20.12.2:5
+ >=kde-frameworks/kbookmarks-${KFMIN}:5
+ >=kde-frameworks/kcmutils-${KFMIN}:5
+ >=kde-frameworks/kconfig-${KFMIN}:5
+ >=kde-frameworks/kconfigwidgets-${KFMIN}:5
+ >=kde-frameworks/kcoreaddons-${KFMIN}:5
+ >=kde-frameworks/ki18n-${KFMIN}:5
+ >=kde-frameworks/kio-${KFMIN}:5
+ >=kde-frameworks/kitemmodels-${KFMIN}:5
+ >=kde-frameworks/kparts-${KFMIN}:5
+ >=kde-frameworks/kwidgetsaddons-${KFMIN}:5
+ >=kde-frameworks/kxmlgui-${KFMIN}:5
+"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-unused-dep.patch"
+ "${FILESDIR}/${P}-implicit-dep.patch"
+ "${FILESDIR}/${P}-missing-lib.patch"
+ "${FILESDIR}/${P}-akonadi-21.12.0.patch" # bug 830580
+)