summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2021-12-05 08:15:09 +0100
committerHans de Graaff <graaff@gentoo.org>2021-12-05 08:15:09 +0100
commitfc63a09ada9f914485d0a5c86e4ffe1f2224e876 (patch)
tree3d5712a78c6026241ff3d5a687f582e2b30f1985 /app-text
parentmedia-fonts/fira-code: add 6.1 (diff)
downloadgentoo-fc63a09ada9f914485d0a5c86e4ffe1f2224e876.tar.gz
gentoo-fc63a09ada9f914485d0a5c86e4ffe1f2224e876.tar.bz2
gentoo-fc63a09ada9f914485d0a5c86e4ffe1f2224e876.zip
app-text/ronn-ng: fix mustache dependency
Package-Manager: Portage-3.0.28, Repoman-3.0.3 Signed-off-by: Hans de Graaff <graaff@gentoo.org>
Diffstat (limited to 'app-text')
-rw-r--r--app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild46
1 files changed, 46 insertions, 0 deletions
diff --git a/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
new file mode 100644
index 000000000000..7353defff61e
--- /dev/null
+++ b/app-text/ronn-ng/ronn-ng-0.9.1-r1.ebuild
@@ -0,0 +1,46 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+USE_RUBY="ruby26 ruby27"
+
+RUBY_FAKEGEM_EXTRADOC="AUTHORS CHANGES README.md"
+RUBY_FAKEGEM_GEMSPEC="ronn-ng.gemspec"
+
+inherit ruby-fakegem
+
+DESCRIPTION="Builds manuals in HTML and Unix man page format from Markdown"
+HOMEPAGE="https://github.com/apjanke/ronn-ng"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~ppc ~ppc64"
+
+IUSE=""
+
+RDEPEND+="!app-text/ronn"
+
+ruby_add_rdepend "
+ >=dev-ruby/kramdown-2.1:2
+ =dev-ruby/mustache-1*
+ >=dev-ruby/nokogiri-1.9.0:0
+"
+
+all_ruby_prepare() {
+ sed -i -e '/mustache/ s/0.7/1.0/' ${RUBY_FAKEGEM_GEMSPEC} || die
+}
+
+each_ruby_prepare() {
+ # Make sure that we always use the right interpreter during tests.
+ sed -i -e "/output/ s:ronn:${RUBY} bin/ronn:" test/test_ronn.rb
+}
+
+all_ruby_compile() {
+ PATH="${S}/bin:${PATH}" rake man || die
+}
+
+all_ruby_install() {
+ all_fakegem_install
+
+ doman man/ronn.1 man/ronn-format.7
+}