summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron U'Ren <aauren@gmail.com>2015-09-08 11:43:28 -0700
committerPatrick McLean <chutzpah@gentoo.org>2015-09-08 15:29:35 -0700
commit7a070bf69b5b4aeeb604b731eeecc46f57055d3f (patch)
tree03409b125994aeb94d7f21e5085a246d9fc24121 /app-vim/autoalign/autoalign-14.ebuild
parentpackage.mask: Moved net-fs/samba mask from >=4.2.0 to >=4.3.0 (diff)
downloadgentoo-7a070bf69b5b4aeeb604b731eeecc46f57055d3f.tar.gz
gentoo-7a070bf69b5b4aeeb604b731eeecc46f57055d3f.tar.bz2
gentoo-7a070bf69b5b4aeeb604b731eeecc46f57055d3f.zip
app-vim/autoalign: Bump version to 14
Package-Manager: portage-2.2.20
Diffstat (limited to 'app-vim/autoalign/autoalign-14.ebuild')
-rw-r--r--app-vim/autoalign/autoalign-14.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/autoalign/autoalign-14.ebuild b/app-vim/autoalign/autoalign-14.ebuild
new file mode 100644
index 000000000000..3f0cf76d76be
--- /dev/null
+++ b/app-vim/autoalign/autoalign-14.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: automatically align bib, c, c++, tex and vim code"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=884"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+if [[ ${PV} != 9999* ]] ; then
+ SRC_URI="mirror://gentoo/${P}.tar.xz
+ http://dev.gentoo.org/~chutzpah/vim/${P}.tar.xz"
+fi
+
+DEPEND="app-arch/xz-utils"
+RDEPEND=">=app-vim/align-30
+ >=app-vim/cecutil-4"
+
+VIM_PLUGIN_HELPFILES="autoalign"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ # Don't use the cecutil.vim included in the tarball, use the one
+ # provided by app-vim/cecutil instead.
+ rm plugin/cecutil.vim
+}