summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/bash-support
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/bash-support')
-rw-r--r--app-vim/bash-support/Manifest3
-rw-r--r--app-vim/bash-support/bash-support-3.12.ebuild22
-rw-r--r--app-vim/bash-support/bash-support-4.1.ebuild21
-rw-r--r--app-vim/bash-support/bash-support-4.2.1.ebuild21
-rw-r--r--app-vim/bash-support/metadata.xml5
5 files changed, 72 insertions, 0 deletions
diff --git a/app-vim/bash-support/Manifest b/app-vim/bash-support/Manifest
new file mode 100644
index 000000000000..5e720344c498
--- /dev/null
+++ b/app-vim/bash-support/Manifest
@@ -0,0 +1,3 @@
+DIST bash-support-3.12.tar.bz2 84647 SHA256 029754c033c3a0e4583d21c1888e19a6b5e982f1eff8d9dec1c540652a571452 SHA512 5c4b778482be34fe9e60389dd6ee94c4db7c067ae5a4d8c00a3dcfd831fbb3e32073f05826b43687536b7dcb892df8f12ba6732fb723e418e12870058a0b1eb5 WHIRLPOOL b36daa58ddb86a9df82628d5906151d5b2a62545f4daaefba08bf48ccf909b52885835b262a44df9f16169511856c78cdce51d9276da4e4b17cce3a8b5e41dc7
+DIST bash-support-4.1.tar.bz2 112365 SHA256 a2b5f309a23a01bcb972b6465faf37bba26a426b4360f675e607b019b8fef42b SHA512 705f2f7e20ebb9925b73d84661382afd54833264cbc1047bb32e95b64e8a10781539edb8c78915ac2765904787321704e622a578d05bfd34a59db980de42bd1a WHIRLPOOL 69f7271d394fcf9adbd503fac9a614ecc780a07ffbe875d53a37245ef80f4ddc5ab8c9269f312da5c94bfd20b42e441a4f3ed447d276f65afddb0f8c76ece717
+DIST bash-support-4.2.1.tar.bz2 115200 SHA256 a231394928bb82db90bb9b6b39b32843fd706998abce07ec712125a1fa968fdd SHA512 12ab39f5cffb58e4adb2137265d6c4f1a61b5f2e360f6866c21ead0a67e02a5445bd12fec5b00b26e5d6102b3aaab99b8b13539a67575067c3ef9b26c4ef8fba WHIRLPOOL 5e2dd6579033d3febbc70a02c6b6aef61cfa27ed6fb185a8a54ecbbe150a953a8ec618d61768023f4c22e8430a88e6aac17539bff92dda5b65c5a764935f91da
diff --git a/app-vim/bash-support/bash-support-3.12.ebuild b/app-vim/bash-support/bash-support-3.12.ebuild
new file mode 100644
index 000000000000..c45dd233f494
--- /dev/null
+++ b/app-vim/bash-support/bash-support-3.12.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2013 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Bash-IDE - Write and run bash scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=365"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,bash-hot-keys.pdf}
+ rm -rf ${PN}/doc
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/bash-support/bash-support-4.1.ebuild b/app-vim/bash-support/bash-support-4.1.ebuild
new file mode 100644
index 000000000000..050095097261
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Bash-IDE - Write and run bash scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=365"
+LICENSE="public-domain"
+KEYWORDS="amd64 x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/bash-support/bash-support-4.2.1.ebuild b/app-vim/bash-support/bash-support-4.2.1.ebuild
new file mode 100644
index 000000000000..068aa89a93e6
--- /dev/null
+++ b/app-vim/bash-support/bash-support-4.2.1.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2014 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Bash-IDE - Write and run bash scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=365"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+
+VIM_PLUGIN_HELPFILES="${PN}"
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,bash-hotkeys.pdf}
+ rm -rf ${PN}/doc
+
+ vim-plugin_src_install
+}
diff --git a/app-vim/bash-support/metadata.xml b/app-vim/bash-support/metadata.xml
new file mode 100644
index 000000000000..d221a8d4b42c
--- /dev/null
+++ b/app-vim/bash-support/metadata.xml
@@ -0,0 +1,5 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+</pkgmetadata>