summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2017-08-17 16:59:07 -0400
committerTim Harder <radhermit@gentoo.org>2017-08-17 16:59:07 -0400
commit28480792f390d1ce411e7250c7adc447b34cc7c5 (patch)
tree7141a0e344e4f26f73140f23582dd779e61a9f0a /app-vim/bufexplorer/bufexplorer-9999.ebuild
parentapp-vim/bufexplorer: remove old (diff)
downloadgentoo-28480792f390d1ce411e7250c7adc447b34cc7c5.tar.gz
gentoo-28480792f390d1ce411e7250c7adc447b34cc7c5.tar.bz2
gentoo-28480792f390d1ce411e7250c7adc447b34cc7c5.zip
app-vim/bufexplorer: add live ebuild
Diffstat (limited to 'app-vim/bufexplorer/bufexplorer-9999.ebuild')
-rw-r--r--app-vim/bufexplorer/bufexplorer-9999.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/bufexplorer/bufexplorer-9999.ebuild b/app-vim/bufexplorer/bufexplorer-9999.ebuild
new file mode 100644
index 000000000000..cd3d232d76ee
--- /dev/null
+++ b/app-vim/bufexplorer/bufexplorer-9999.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/jlanzarotta/bufexplorer.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/jlanzarotta/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+fi
+
+DESCRIPTION="vim plugin: easily browse vim buffers"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=42 https://github.com/jlanzarotta/bufexplorer"
+LICENSE="BSD"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm LICENSE README.md || die
+}