summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-12 19:58:25 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-12 19:58:56 -0700
commita08e6eca21713e61e788872d75545fdb6a881097 (patch)
tree44dfea9322b30474c607425e1b2e138f8cdca719 /app-vim/fugitive/fugitive-3.1.ebuild
parentdev-java/gwt: Patch (by me) to not run git (diff)
downloadgentoo-a08e6eca21713e61e788872d75545fdb6a881097.tar.gz
gentoo-a08e6eca21713e61e788872d75545fdb6a881097.tar.bz2
gentoo-a08e6eca21713e61e788872d75545fdb6a881097.zip
app-vim/fugitive: version bump to 3.1
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/fugitive/fugitive-3.1.ebuild')
-rw-r--r--app-vim/fugitive/fugitive-3.1.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/fugitive/fugitive-3.1.ebuild b/app-vim/fugitive/fugitive-3.1.ebuild
new file mode 100644
index 000000000000..0d4da8993529
--- /dev/null
+++ b/app-vim/fugitive/fugitive-3.1.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit vim-plugin
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/tpope/vim-fugitive.git"
+else
+ SRC_URI="https://github.com/tpope/vim-fugitive/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~ppc-macos ~x64-macos"
+ S="${WORKDIR}/vim-${P}"
+fi
+
+DESCRIPTION="vim plugin: a git wrapper for vim"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=2975 https://github.com/tpope/vim-fugitive/"
+LICENSE="vim"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+RDEPEND="dev-vcs/git"