summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-16 00:05:06 -0400
committerTim Harder <radhermit@gentoo.org>2016-03-16 00:09:18 -0400
commit4a1ffe4a266966e61d560ad7cd46103a0da80a89 (patch)
tree91ba675748f105519c778ccf66eab11456f465e0 /app-vim/gitgutter/gitgutter-99999999.ebuild
parentgames-action/openclonk: make sure the active compiler can deal with the fancy... (diff)
downloadgentoo-4a1ffe4a266966e61d560ad7cd46103a0da80a89.tar.gz
gentoo-4a1ffe4a266966e61d560ad7cd46103a0da80a89.tar.bz2
gentoo-4a1ffe4a266966e61d560ad7cd46103a0da80a89.zip
app-vim/gitgutter: version bump to new snapshot
Diffstat (limited to 'app-vim/gitgutter/gitgutter-99999999.ebuild')
-rw-r--r--app-vim/gitgutter/gitgutter-99999999.ebuild14
1 files changed, 10 insertions, 4 deletions
diff --git a/app-vim/gitgutter/gitgutter-99999999.ebuild b/app-vim/gitgutter/gitgutter-99999999.ebuild
index eb4098068809..6ae5ba5443f6 100644
--- a/app-vim/gitgutter/gitgutter-99999999.ebuild
+++ b/app-vim/gitgutter/gitgutter-99999999.ebuild
@@ -1,17 +1,23 @@
-# Copyright 1999-2014 Gentoo Foundation
+# Copyright 1999-2016 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
# $Id$
EAPI=5
-inherit vim-plugin git-r3
+inherit vim-plugin
-EGIT_REPO_URI="git://github.com/airblade/vim-gitgutter.git"
+if [[ ${PV} == 9999* ]]; then
+ EGIT_REPO_URI="git://github.com/airblade/vim-gitgutter.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64 ~x86"
+fi
-DESCRIPTION="vim plugin: shows a git diff summary in the sign column and stages/reverts individual hunks"
+DESCRIPTION="vim plugin: shows a git diff in the sign column and stages/reverts hunks"
HOMEPAGE="https://github.com/airblade/vim-gitgutter/"
LICENSE="MIT"
VIM_PLUGIN_HELPFILES="${PN}.txt"
src_prepare() {
rm README* screenshot.png || die
+ rm -rf test || die
}