summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-06-06 22:23:47 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-06-06 22:38:00 +0000
commit0377401e0f3f693adb9544499b170c29f2907691 (patch)
tree5ef44fb540e1ea556b5205b5ab1c8d4402450852 /app-vim/indentpython
parentmail-filter/opensmtpd-extras: snapshot version bump (diff)
downloadgentoo-0377401e0f3f693adb9544499b170c29f2907691.tar.gz
gentoo-0377401e0f3f693adb9544499b170c29f2907691.tar.bz2
gentoo-0377401e0f3f693adb9544499b170c29f2907691.zip
app-vim/indentpython: Add vim script to indent Python code.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/indentpython')
-rw-r--r--app-vim/indentpython/Manifest1
-rw-r--r--app-vim/indentpython/indentpython-0.3.ebuild17
-rw-r--r--app-vim/indentpython/metadata.xml8
3 files changed, 26 insertions, 0 deletions
diff --git a/app-vim/indentpython/Manifest b/app-vim/indentpython/Manifest
new file mode 100644
index 000000000000..3facd6054187
--- /dev/null
+++ b/app-vim/indentpython/Manifest
@@ -0,0 +1 @@
+DIST indentpython-0.3.zip 2682 SHA256 0e6e16f80e21d173d6f9b87efcb7d2027026d8e7125156a01a9367f7a9489baf SHA512 d358579357d5197dc035816b02557b8e84d5f0c85fb6433d171b9880e211dee75ef6f5fd7a37651677591c6c31a570c39094d6bbd5052a29ef344ec18b0e13c5 WHIRLPOOL 976555635d61360b55deb975c78ccf079eb17bf66595babf6c307f0f7eb0e5c68fd9a26abd85d7d5181942524388ef3dfe7795767cba19e2097ec77c7859c5b8
diff --git a/app-vim/indentpython/indentpython-0.3.ebuild b/app-vim/indentpython/indentpython-0.3.ebuild
new file mode 100644
index 000000000000..d3e592f50c06
--- /dev/null
+++ b/app-vim/indentpython/indentpython-0.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Indent Python code according to PEP8"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=974"
+SRC_URI="https://github.com/vim-scripts/${PN}.vim/archive/${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="app-arch/unzip"
+
+S="${WORKDIR}/${PN}.vim-${PV}"
diff --git a/app-vim/indentpython/metadata.xml b/app-vim/indentpython/metadata.xml
new file mode 100644
index 000000000000..84f8f1cf6bcb
--- /dev/null
+++ b/app-vim/indentpython/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+</pkgmetadata>