summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHorea Christian <horea.christ@yandex.com>2017-10-30 20:38:45 +0100
committerPatrice Clement <monsieurp@gentoo.org>2017-10-30 23:51:27 +0100
commite3751aa7badec2f69d7950224de386c90b3262d1 (patch)
treef883eb9d254851359bd626e5c6534341c974fcdd /app-vim/jedi
parentdev-embedded/avr-libc: stable 2.0.0 for amd64, bug #620316 (thanks to Richard... (diff)
downloadgentoo-e3751aa7badec2f69d7950224de386c90b3262d1.tar.gz
gentoo-e3751aa7badec2f69d7950224de386c90b3262d1.tar.bz2
gentoo-e3751aa7badec2f69d7950224de386c90b3262d1.zip
app-vim/jedi-vim: new ebuild.
Vim plugin to the autocompletion library Jedi. Package-Manager: Portage-2.3.11, Repoman-2.3.3 Closes: https://github.com/gentoo/gentoo/pull/6093
Diffstat (limited to 'app-vim/jedi')
-rw-r--r--app-vim/jedi/Manifest1
-rw-r--r--app-vim/jedi/jedi-0.8_p20171015.ebuild33
-rw-r--r--app-vim/jedi/metadata.xml23
3 files changed, 57 insertions, 0 deletions
diff --git a/app-vim/jedi/Manifest b/app-vim/jedi/Manifest
new file mode 100644
index 000000000000..326df8ed36b9
--- /dev/null
+++ b/app-vim/jedi/Manifest
@@ -0,0 +1 @@
+DIST 77924398bd594e238766153cec97ace62650f082.zip 43567 SHA256 a120fc6c611f4ee37771d6deb4b871a2d40ca7125231e6f262aa28772eb06880 SHA512 d69fa77ada22b0c75b7ec4ad1765035454312707ffb0f8a0bb0de4928e5fd21b08e39ab28b3f0ff9b37c8eb5389bc44c507fa2a08c0322510a57a91d7de028e6 WHIRLPOOL 150efcb21de8cd8fe523116f67999a99ae28438779eba40a1d8889896000ceebbd1fc9c8a22d0bfacd1619ad36d3ef60df2d97d254075c3a82b2f091e5d93d55
diff --git a/app-vim/jedi/jedi-0.8_p20171015.ebuild b/app-vim/jedi/jedi-0.8_p20171015.ebuild
new file mode 100644
index 000000000000..e991f5795bf7
--- /dev/null
+++ b/app-vim/jedi/jedi-0.8_p20171015.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+PYTHON_COMPAT=( python{2_7,3_4} )
+
+inherit vim-plugin python-r1 python-utils-r1
+
+# Commit Date: Sun Oct 15 20:51:54 2017 +0200
+COMMIT="77924398bd594e238766153cec97ace62650f082"
+
+DESCRIPTION="vim plugin: binding to the autocompletion library jedi"
+HOMEPAGE="https://github.com/davidhalter/jedi-vim"
+SRC_URI="https://github.com/davidhalter/jedi-vim/archive/${COMMIT}.zip"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+RDEPEND="dev-python/jedi[${PYTHON_USEDEP}]"
+DEPEND="app-editors/vim[python]"
+
+S="${WORKDIR}/jedi-vim-${COMMIT}"
+
+# Tests are broken.
+RESTRICT="test"
+
+# Makefile tries hard to call tests so let's silence this phase.
+src_compile() { :; }
+
+src_install() {
+ vim-plugin_src_install
+}
diff --git a/app-vim/jedi/metadata.xml b/app-vim/jedi/metadata.xml
new file mode 100644
index 000000000000..e29e8e7eb84b
--- /dev/null
+++ b/app-vim/jedi/metadata.xml
@@ -0,0 +1,23 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>horea.christ@gmail.com</email>
+ <name>Horea Christian</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <maintainer type="project">
+ <email>vim@gentoo.org</email>
+ <name>Gentoo Vim Project</name>
+ </maintainer>
+ <longdescription lang="en">
+ Jedi-vim is a VIM binding to the autocompletion library Jedi.
+ Apart from that, jedi-vim provides a number of keybindings.
+ </longdescription>
+ <upstream>
+ <remote-id type="github">davidhalter/jedi-vim</remote-id>
+ </upstream>
+</pkgmetadata>