summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAdrian Schollmeyer <nex+b-g-o@nexadn.de>2024-02-20 18:32:41 +0100
committerJoonas Niilola <juippis@gentoo.org>2024-03-29 09:37:58 +0200
commitb4b671048073e9b291b52672320250e4c1c127e3 (patch)
treefb0a818ad115cf2b97b780ccaa00361f223141ca /app-vim/lightline/lightline-0_pre20240113.ebuild
parentdev-ruby/async-container: add 0.18.0 (diff)
downloadgentoo-b4b671048073e9b291b52672320250e4c1c127e3.tar.gz
gentoo-b4b671048073e9b291b52672320250e4c1c127e3.tar.bz2
gentoo-b4b671048073e9b291b52672320250e4c1c127e3.zip
app-vim/lightline: add 0_pre20240113
Signed-off-by: Adrian Schollmeyer <nex+b-g-o@nexadn.de> Signed-off-by: Joonas Niilola <juippis@gentoo.org>
Diffstat (limited to 'app-vim/lightline/lightline-0_pre20240113.ebuild')
-rw-r--r--app-vim/lightline/lightline-0_pre20240113.ebuild21
1 files changed, 21 insertions, 0 deletions
diff --git a/app-vim/lightline/lightline-0_pre20240113.ebuild b/app-vim/lightline/lightline-0_pre20240113.ebuild
new file mode 100644
index 000000000000..0cdebfc81b8a
--- /dev/null
+++ b/app-vim/lightline/lightline-0_pre20240113.ebuild
@@ -0,0 +1,21 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/itchyny/lightline.vim/"
+else
+ LIGHTLINE_COMMIT="58c97bc21c6f657d3babdd4eefce7593e30e75ce"
+ SRC_URI="https://github.com/itchyny/lightline.vim/archive/${LIGHTLINE_COMMIT}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86"
+ S="${WORKDIR}/${PN}.vim-${LIGHTLINE_COMMIT}"
+fi
+
+DESCRIPTION="vim plugin: A light and configurable statusline/tabline"
+HOMEPAGE="https://github.com/itchyny/lightline.vim/"
+LICENSE="MIT"
+VIM_PLUGIN_HELPFILES="${PN}"