summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2020-01-14 21:42:14 -0700
committerTim Harder <radhermit@gentoo.org>2020-01-14 21:44:56 -0700
commit3bc3a315f80004d894442498ee620717567f4893 (patch)
tree9071bc3ed920ef8ef0a6a46383b7a1bb25c9da38 /app-vim/nerdtree/nerdtree-6.4.3.ebuild
parentsys-libs/uclibc-ng: mark 1.0.30-r1 stable for arm (diff)
downloadgentoo-3bc3a315f80004d894442498ee620717567f4893.tar.gz
gentoo-3bc3a315f80004d894442498ee620717567f4893.tar.bz2
gentoo-3bc3a315f80004d894442498ee620717567f4893.zip
app-vim/nerdtree: version bump to 6.4.3
Signed-off-by: Tim Harder <radhermit@gentoo.org>
Diffstat (limited to 'app-vim/nerdtree/nerdtree-6.4.3.ebuild')
-rw-r--r--app-vim/nerdtree/nerdtree-6.4.3.ebuild25
1 files changed, 25 insertions, 0 deletions
diff --git a/app-vim/nerdtree/nerdtree-6.4.3.ebuild b/app-vim/nerdtree/nerdtree-6.4.3.ebuild
new file mode 100644
index 000000000000..99a848dacfcf
--- /dev/null
+++ b/app-vim/nerdtree/nerdtree-6.4.3.ebuild
@@ -0,0 +1,25 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit vim-plugin
+
+if [[ ${PV} == "9999" ]] ; then
+ EGIT_REPO_URI="https://github.com/scrooloose/nerdtree.git"
+ inherit git-r3
+else
+ SRC_URI="https://github.com/scrooloose/${PN}/archive/${PV}.tar.gz -> ${P}.tar.gz"
+ KEYWORDS="~amd64 ~x86 ~x64-macos"
+fi
+
+DESCRIPTION="vim plugin: A tree explorer plugin for navigating the filesystem"
+HOMEPAGE="https://www.vim.org/scripts/script.php?script_id=1658 https://github.com/scrooloose/nerdtree"
+LICENSE="WTFPL-2"
+
+VIM_PLUGIN_HELPFILES="NERD_tree"
+
+src_prepare() {
+ rm LICENCE screenshot.png _config.yml || die
+ default
+}