summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-12 20:21:28 -0500
committerTim Harder <radhermit@gentoo.org>2016-03-12 20:22:55 -0500
commitaa51338ebc9fd130cba62158129e274cb2af7315 (patch)
tree8ba1f11573271884ec0985a05c4a45325c34307f /app-vim/perl-support/perl-support-5.3.2.ebuild
parentapp-vim/calendar: remove old (diff)
downloadgentoo-aa51338ebc9fd130cba62158129e274cb2af7315.tar.gz
gentoo-aa51338ebc9fd130cba62158129e274cb2af7315.tar.bz2
gentoo-aa51338ebc9fd130cba62158129e274cb2af7315.zip
app-vim/perl-support: version bump to 5.3.2
Diffstat (limited to 'app-vim/perl-support/perl-support-5.3.2.ebuild')
-rw-r--r--app-vim/perl-support/perl-support-5.3.2.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/perl-support/perl-support-5.3.2.ebuild b/app-vim/perl-support/perl-support-5.3.2.ebuild
new file mode 100644
index 000000000000..2614baa6e2f3
--- /dev/null
+++ b/app-vim/perl-support/perl-support-5.3.2.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl-IDE - Write and run Perl scripts using menus and hotkeys"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=556"
+LICENSE="GPL-2 GPL-2+"
+KEYWORDS="~amd64 ~ppc ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+
+VIM_PLUGIN_HELPFILES="perlsupport.txt"
+
+RDEPEND="dev-perl/Perl-Tags
+ dev-perl/Perl-Critic"
+
+src_prepare() {
+ # Don't set tabstop and shiftwidth
+ sed -i '/=4/s/^/"/' ftplugin/perl.vim
+}
+
+src_install() {
+ dodoc ${PN}/doc/{ChangeLog,perl-hot-keys.pdf}
+ rm -r ${PN}/doc/ || die
+
+ vim-plugin_src_install
+}