summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-24 00:25:39 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-24 00:25:57 +0200
commit79f467450adbe10133eb2706cf7ba27f4057a236 (patch)
tree3cb6e481c0648ca058cdf67297042216578bac5c /app-vim/perlomni/perlomni-2.5.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-79f467450adbe10133eb2706cf7ba27f4057a236.tar.gz
gentoo-79f467450adbe10133eb2706cf7ba27f4057a236.tar.bz2
gentoo-79f467450adbe10133eb2706cf7ba27f4057a236.zip
app-vim/perlomni: add perlomni to the tree.
perl-completion is a plugin which supports basic Perl completion for vim. Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/perlomni/perlomni-2.5.ebuild')
-rw-r--r--app-vim/perlomni/perlomni-2.5.ebuild28
1 files changed, 28 insertions, 0 deletions
diff --git a/app-vim/perlomni/perlomni-2.5.ebuild b/app-vim/perlomni/perlomni-2.5.ebuild
new file mode 100644
index 000000000000..28b0746ba030
--- /dev/null
+++ b/app-vim/perlomni/perlomni-2.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Perl omni completion"
+HOMEPAGE="https://github.com/c9s/perlomni.vim"
+SRC_URI="https://github.com/c9s/${PN}.vim/archive/v${PV}.zip -> ${P}.zip"
+LICENSE="vim.org"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~x86"
+
+DEPEND="
+ app-arch/unzip
+ dev-lang/perl"
+
+S="${WORKDIR}/${PN}.vim-${PV}"
+
+src_prepare() {
+ default
+ rm -v Makefile config.mk README.mkd README.mkd.old win32-install.bat TODO || die
+}
+
+src_compile() {
+ :;
+}