summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2017-08-22 23:51:19 +0200
committerPatrice Clement <monsieurp@gentoo.org>2017-08-23 09:28:18 +0200
commitf52452f5b9bcd54dcfe0471d2306691acf87d0c4 (patch)
treef339c2e9d9cb71c700e16c59d1668e10c4225a98 /app-vim/phpdocs/phpdocs-0.26-r1.ebuild
parentwww-client/vivaldi: Old. (diff)
downloadgentoo-f52452f5b9bcd54dcfe0471d2306691acf87d0c4.tar.gz
gentoo-f52452f5b9bcd54dcfe0471d2306691acf87d0c4.tar.bz2
gentoo-f52452f5b9bcd54dcfe0471d2306691acf87d0c4.zip
app-vim/phpdocs: EAPI 6 bump.
Package-Manager: Portage-2.3.6, Repoman-2.3.1
Diffstat (limited to 'app-vim/phpdocs/phpdocs-0.26-r1.ebuild')
-rw-r--r--app-vim/phpdocs/phpdocs-0.26-r1.ebuild18
1 files changed, 18 insertions, 0 deletions
diff --git a/app-vim/phpdocs/phpdocs-0.26-r1.ebuild b/app-vim/phpdocs/phpdocs-0.26-r1.ebuild
new file mode 100644
index 000000000000..7cc6c7dd7550
--- /dev/null
+++ b/app-vim/phpdocs/phpdocs-0.26-r1.ebuild
@@ -0,0 +1,18 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: PHPDoc Support in VIM"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=520"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+
+VIM_PLUGIN_HELPURI="http://www.vim.org/scripts/script.php?script_id=520"
+
+src_prepare() {
+ default
+ sed -i 's/\r$//' "${S}"/plugin/phpdoc.vim || die "sed failed"
+}