summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-05-12 12:59:51 +0000
committerPatrice Clement <monsieurp@gentoo.org>2016-05-12 13:17:42 +0000
commitf25308cb2ce223a5aa785578ad93cd502651ca67 (patch)
treea135b5f48649f5b1c6948b5f6502e81af8337f8f /app-vim/pydiction/pydiction-1.2.3.ebuild
parentwww-plugins/chrome-binary-plugins: automated update (diff)
downloadgentoo-f25308cb2ce223a5aa785578ad93cd502651ca67.tar.gz
gentoo-f25308cb2ce223a5aa785578ad93cd502651ca67.tar.bz2
gentoo-f25308cb2ce223a5aa785578ad93cd502651ca67.zip
app-vim/pydiction: Add ebuild to the tree.
Package-Manager: portage-2.2.26
Diffstat (limited to 'app-vim/pydiction/pydiction-1.2.3.ebuild')
-rw-r--r--app-vim/pydiction/pydiction-1.2.3.ebuild22
1 files changed, 22 insertions, 0 deletions
diff --git a/app-vim/pydiction/pydiction-1.2.3.ebuild b/app-vim/pydiction/pydiction-1.2.3.ebuild
new file mode 100644
index 000000000000..ef3e970c42a4
--- /dev/null
+++ b/app-vim/pydiction/pydiction-1.2.3.ebuild
@@ -0,0 +1,22 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: Tab-complete your Python code"
+HOMEPAGE="https://rkulla.github.io/pydiction/"
+SRC_URI="https://dev.gentoo.org/~monsieurp/packages/${P}.zip"
+LICENSE="vim"
+KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~sparc ~x86"
+S="${WORKDIR}/${PN}"
+
+src_install() {
+ insinto "/usr/share/${PN}"
+ local pyfiles=( complete-dict pydiction.py )
+ doins "${pyfiles[@]}"
+ rm -v "${pyfiles[@]}" || die
+ vim-plugin_src_install
+}