summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2015-08-08 13:49:04 -0700
committerRobin H. Johnson <robbat2@gentoo.org>2015-08-08 17:38:18 -0700
commit56bd759df1d0c750a065b8c845e93d5dfa6b549d (patch)
tree3f91093cdb475e565ae857f1c5a7fd339e2d781e /app-vim/screen
downloadgentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.gz
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.tar.bz2
gentoo-56bd759df1d0c750a065b8c845e93d5dfa6b549d.zip
proj/gentoo: Initial commit
This commit represents a new era for Gentoo: Storing the gentoo-x86 tree in Git, as converted from CVS. This commit is the start of the NEW history. Any historical data is intended to be grafted onto this point. Creation process: 1. Take final CVS checkout snapshot 2. Remove ALL ChangeLog* files 3. Transform all Manifests to thin 4. Remove empty Manifests 5. Convert all stale $Header$/$Id$ CVS keywords to non-expanded Git $Id$ 5.1. Do not touch files with -kb/-ko keyword flags. Signed-off-by: Robin H. Johnson <robbat2@gentoo.org> X-Thanks: Alec Warner <antarus@gentoo.org> - did the GSoC 2006 migration tests X-Thanks: Robin H. Johnson <robbat2@gentoo.org> - infra guy, herding this project X-Thanks: Nguyen Thai Ngoc Duy <pclouds@gentoo.org> - Former Gentoo developer, wrote Git features for the migration X-Thanks: Brian Harring <ferringb@gentoo.org> - wrote much python to improve cvs2svn X-Thanks: Rich Freeman <rich0@gentoo.org> - validation scripts X-Thanks: Patrick Lauer <patrick@gentoo.org> - Gentoo dev, running new 2014 work in migration X-Thanks: Michał Górny <mgorny@gentoo.org> - scripts, QA, nagging X-Thanks: All of other Gentoo developers - many ideas and lots of paint on the bikeshed
Diffstat (limited to 'app-vim/screen')
-rw-r--r--app-vim/screen/Manifest3
-rw-r--r--app-vim/screen/metadata.xml8
-rw-r--r--app-vim/screen/screen-1.3.ebuild17
-rw-r--r--app-vim/screen/screen-1.4.ebuild17
-rw-r--r--app-vim/screen/screen-1.5.ebuild28
5 files changed, 73 insertions, 0 deletions
diff --git a/app-vim/screen/Manifest b/app-vim/screen/Manifest
new file mode 100644
index 000000000000..422227dfff3b
--- /dev/null
+++ b/app-vim/screen/Manifest
@@ -0,0 +1,3 @@
+DIST screen-1.3.tar.bz2 12047 SHA256 c0fff965c1922eb66cb49dda8d4a00d7bac30c7890ebb8ab2bbc74b316b2bd79 SHA512 55e986518cd8a89557ab2b7034e10c23beeacade2ee676d6b0ecc105ced0a6f2388cdaa45e48c2916db34052442151bd1b2488a80ad3821b7cc8a30e3be998cc WHIRLPOOL 4d675fafec8c49bf93ca49fce8a4896f887840292a5960b23b47b4e218e2b15b2b11a28d09a4b0d84e0cb16b332298f6e22b4320d161cdabc4e0d977d1834343
+DIST screen-1.4.tar.bz2 12690 SHA256 fc2005d57a9093d08975ac2fec2db53cc46f7d3db9b47f9ca5e423750dc81da4 SHA512 4474ec69719b01bc627b7621f1fd994f6acfa4c066a8e0761feca17652766b80a6686ce0611c1b10d3829000a102596297955be6f344d2bec0b62c3d17703c0d WHIRLPOOL 5d86f9a78c2a4fc63be8888b67cf15fb82e258c7d3c22593a6ae4218b1c08efdb222e6c9e48a18dfd894c6e7880b0cddb3539d17ee3076d464c6783ee50606ab
+DIST screen-1.5.tar.gz 16395 SHA256 5024d5288240d0a9261ab436dd831bec51e4c03e2a486d7deb2bd761ab854521 SHA512 eef9fbe327b1ef16cb5d5ffb851b04c6d4c8f1b8ef215ae9a0f05c91eaa39538bb470fc1ecd2cbb7697ec23a4fdce2515b97818b47050cbfc4fe7da199648549 WHIRLPOOL 23c7afb8a4258cd58c95774c80b36f4f4bc3b6edaee536db4b8d152cbc75e8bdc9bf8ae5554e1c47bf7e6b8a4a1df41054b59de3abb4572597d282ba3183427b
diff --git a/app-vim/screen/metadata.xml b/app-vim/screen/metadata.xml
new file mode 100644
index 000000000000..f834882c8236
--- /dev/null
+++ b/app-vim/screen/metadata.xml
@@ -0,0 +1,8 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <herd>vim</herd>
+ <upstream>
+ <remote-id type="github">vim-scripts/Screen-vim---gnu-screentmux</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/app-vim/screen/screen-1.3.ebuild b/app-vim/screen/screen-1.3.ebuild
new file mode 100644
index 000000000000..de7ead3525fe
--- /dev/null
+++ b/app-vim/screen/screen-1.3.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: simulate a split shell with screen or tmux"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2711"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="screen.txt"
+
+RDEPEND="|| ( app-misc/screen app-misc/tmux )"
diff --git a/app-vim/screen/screen-1.4.ebuild b/app-vim/screen/screen-1.4.ebuild
new file mode 100644
index 000000000000..de7ead3525fe
--- /dev/null
+++ b/app-vim/screen/screen-1.4.ebuild
@@ -0,0 +1,17 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="3"
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: simulate a split shell with screen or tmux"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2711"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="screen.txt"
+
+RDEPEND="|| ( app-misc/screen app-misc/tmux )"
diff --git a/app-vim/screen/screen-1.5.ebuild b/app-vim/screen/screen-1.5.ebuild
new file mode 100644
index 000000000000..1141a38eb804
--- /dev/null
+++ b/app-vim/screen/screen-1.5.ebuild
@@ -0,0 +1,28 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI="4"
+
+inherit vim-plugin
+
+MY_PN="Screen-vim---gnu-screentmux"
+DESCRIPTION="vim plugin: simulate a split shell with screen or tmux"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2711"
+SRC_URI="https://github.com/vim-scripts/${MY_PN}/tarball/${PV} -> ${P}.tar.gz"
+LICENSE="public-domain"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="screen.txt"
+
+RDEPEND="|| ( app-misc/screen app-misc/tmux )"
+
+src_unpack() {
+ unpack ${A}
+ mv *-${MY_PN}-* "${S}"
+}
+
+src_prepare() {
+ rm README || die
+}