summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPatrice Clement <monsieurp@gentoo.org>2016-09-02 15:19:40 +0200
committerPatrice Clement <monsieurp@gentoo.org>2016-09-02 15:49:23 +0200
commitce8366c34b3dc993f4a40e96136d5cd2c2c44e2b (patch)
tree1d920e90907b3afa80a0478f26907b5725e5a58c /app-vim/showmarks/showmarks-2.2-r1.ebuild
parentmedia-sound/mixxx: Added sub-slot dependency on media-video/ffmpeg. (diff)
downloadgentoo-ce8366c34b3dc993f4a40e96136d5cd2c2c44e2b.tar.gz
gentoo-ce8366c34b3dc993f4a40e96136d5cd2c2c44e2b.tar.bz2
gentoo-ce8366c34b3dc993f4a40e96136d5cd2c2c44e2b.zip
app-vim/showmarks: EAPI 6 bump.
Package-Manager: portage-2.2.28
Diffstat (limited to 'app-vim/showmarks/showmarks-2.2-r1.ebuild')
-rw-r--r--app-vim/showmarks/showmarks-2.2-r1.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/app-vim/showmarks/showmarks-2.2-r1.ebuild b/app-vim/showmarks/showmarks-2.2-r1.ebuild
new file mode 100644
index 000000000000..2c5da044c6ed
--- /dev/null
+++ b/app-vim/showmarks/showmarks-2.2-r1.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+
+inherit vim-plugin
+
+DESCRIPTION="vim plugin: show location marks visually"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=152"
+
+LICENSE="public-domain"
+KEYWORDS="~alpha ~amd64 ~ia64 ~mips ~ppc ~sparc ~x86"
+IUSE=""
+
+VIM_PLUGIN_HELPFILES="showmarks.txt"
+
+src_prepare() {
+ default
+
+ mkdir "${S}"/doc || die "can't make doc dir"
+
+ # This plugin uses an 'automatic HelpExtractor' variant. This causes
+ # problems for us during the unmerge. Fortunately, sed can fix this
+ # for us.
+ sed -e '1,/^" HelpExtractorDoc:$/d' \
+ "${S}"/plugin/showmarks.vim > "${S}"/doc/showmarks.txt \
+ || die "help extraction failed"
+ sed -i -e '/^" HelpExtractor:$/,$d' "${S}"/plugin/showmarks.vim \
+ || die "help extract remove failed"
+}