summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-03-12 20:56:22 -0500
committerTim Harder <radhermit@gentoo.org>2016-03-12 20:56:22 -0500
commit3a3389d469c74ba0607f3cf4f0521ef1dfb50669 (patch)
tree0a504b870f6b9c14ea13757f5d3700701e44ebe3 /app-vim/snipmate
parentapp-vim/perl-support: drop to ~ppc (diff)
downloadgentoo-3a3389d469c74ba0607f3cf4f0521ef1dfb50669.tar.gz
gentoo-3a3389d469c74ba0607f3cf4f0521ef1dfb50669.tar.bz2
gentoo-3a3389d469c74ba0607f3cf4f0521ef1dfb50669.zip
app-vim/snipmate: version bump to 0.87 (bug #538490)
Diffstat (limited to 'app-vim/snipmate')
-rw-r--r--app-vim/snipmate/Manifest1
-rw-r--r--app-vim/snipmate/snipmate-0.87.ebuild26
2 files changed, 27 insertions, 0 deletions
diff --git a/app-vim/snipmate/Manifest b/app-vim/snipmate/Manifest
index 3316a3d43974..f710aa112bed 100644
--- a/app-vim/snipmate/Manifest
+++ b/app-vim/snipmate/Manifest
@@ -1 +1,2 @@
DIST snipmate-0.83.zip 30761 SHA256 9f22e7592e074dbafb006b502436a5ccb9c54d30aac2f718b16752f70d19de0e SHA512 3fcc6fccefa356bd78b2a23e2e1613bcdc6d56c103288949fed4b0df4bc38122bd522040b7ac1572e30e44b2e9a37f6197af554da5a301e310d81f8221822184 WHIRLPOOL f56433d19eb75c7f68a63bcdec727f24f3ebef4a8b3ce6838459e646dd83399afef7b110efe1bb9e99c1d8879acb7e8697839a8001ed5cd16cebb96a06116938
+DIST snipmate-0.87.tar.gz 20624 SHA256 4ee93136a378ff3037bd2992f028cb475231d1f589c4c700ebb0e3f9af2cb0de SHA512 36ef13676e0ff8085456883ad09c111158be6051251a15b428a05d3caee678a6c8ab092694fdf876ecdf19b93e04cb8ff67108dda83ab602250f5ae42602e6b9 WHIRLPOOL 82d588d25aef73b73874d1d541b8bf63d5497e54a667bf064237a5fde615f5c5ec15d9d208e8781f0035e5e4d08a234b6d79332ebf3da8b3dbc94fa942bda3dd
diff --git a/app-vim/snipmate/snipmate-0.87.ebuild b/app-vim/snipmate/snipmate-0.87.ebuild
new file mode 100644
index 000000000000..9a1feef50c86
--- /dev/null
+++ b/app-vim/snipmate/snipmate-0.87.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=5
+
+inherit vim-plugin
+
+MY_PN=vim-${PN}
+MY_P=${MY_PN}-${PV}
+
+DESCRIPTION="vim plugin: TextMate-style snippets"
+HOMEPAGE="http://www.vim.org/scripts/script.php?script_id=2540 https://github.com/garbas/vim-snipmate"
+SRC_URI="https://github.com/garbas/${MY_PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="~amd64 ~x86"
+
+S=${WORKDIR}/${MY_P}
+
+VIM_PLUGIN_HELPFILES="SnipMate"
+VIM_PLUGIN_MESSAGES="filetype"
+
+src_prepare() {
+ rm addon-info.json || die
+}