summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichał Górny <mgorny@gentoo.org>2020-02-07 13:15:40 +0100
committerMichał Górny <mgorny@gentoo.org>2020-02-09 17:17:32 +0100
commit8cc219671821cf212a969216cbc3c3067054e581 (patch)
treecc141520d03d147958bb0933884a9a69c8e99e17 /app-vim/splice/splice-1.1.0-r2.ebuild
parentapp-vim/slimv: Switch to PYTHON_SINGLE_USEDEP (diff)
downloadgentoo-8cc219671821cf212a969216cbc3c3067054e581.tar.gz
gentoo-8cc219671821cf212a969216cbc3c3067054e581.tar.bz2
gentoo-8cc219671821cf212a969216cbc3c3067054e581.zip
app-vim/splice: Switch to PYTHON_SINGLE_USEDEP
Signed-off-by: Michał Górny <mgorny@gentoo.org>
Diffstat (limited to 'app-vim/splice/splice-1.1.0-r2.ebuild')
-rw-r--r--app-vim/splice/splice-1.1.0-r2.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/app-vim/splice/splice-1.1.0-r2.ebuild b/app-vim/splice/splice-1.1.0-r2.ebuild
new file mode 100644
index 000000000000..84be23b68c94
--- /dev/null
+++ b/app-vim/splice/splice-1.1.0-r2.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://bitbucket.org/sjl/splice.vim/ https://www.vim.org/scripts/script.php?script_id=4026"
+SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || (
+ app-editors/vim[python,${PYTHON_SINGLE_USEDEP}]
+ app-editors/gvim[python,${PYTHON_SINGLE_USEDEP}]
+ )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm .[a-z]* Makefile LICENSE.markdown package.sh || die
+ rm -r site || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}