summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2016-10-31 00:45:06 -0400
committerTim Harder <radhermit@gentoo.org>2016-10-31 00:45:06 -0400
commit0776c76c7b97b12a3d85416e87225466ab9a7529 (patch)
treef90504a8676a597ce252e0e0b5ff3524c78494bd /app-vim/splice/splice-1.1.0.ebuild
parentapp-vim/gist: version bump to 7.3 (diff)
downloadgentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.tar.gz
gentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.tar.bz2
gentoo-0776c76c7b97b12a3d85416e87225466ab9a7529.zip
app-vim/splice: version bump to 1.1.0
Diffstat (limited to 'app-vim/splice/splice-1.1.0.ebuild')
-rw-r--r--app-vim/splice/splice-1.1.0.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/app-vim/splice/splice-1.1.0.ebuild b/app-vim/splice/splice-1.1.0.ebuild
new file mode 100644
index 000000000000..a4d376cca1ee
--- /dev/null
+++ b/app-vim/splice/splice-1.1.0.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Id$
+
+EAPI=6
+PYTHON_COMPAT=( python2_7 )
+
+inherit vim-plugin python-single-r1 vcs-snapshot
+
+DESCRIPTION="vim plugin: resolve conflicts during three-way merges"
+HOMEPAGE="https://bitbucket.org/sjl/splice.vim http://vim.sourceforge.net/scripts/script.php?script_id=4026"
+SRC_URI="https://bitbucket.org/sjl/${PN}.vim/get/v${PV}.tar.gz -> ${P}.tar.gz"
+LICENSE="MIT"
+KEYWORDS="amd64 x86"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="|| ( app-editors/vim[python] app-editors/gvim[python] )"
+
+VIM_PLUGIN_HELPFILES="${PN}.txt"
+
+src_prepare() {
+ default
+ rm .[a-z]* Makefile LICENSE.markdown package.sh || die
+ rm -r site || die
+}
+
+src_install() {
+ vim-plugin_src_install
+ python_optimize "${ED}"/usr/share/vim/vimfiles/autoload/splicelib
+}